Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 06-03-2016 12:03 PM
I'm using Ambari 2.2.1.0 and HDP 2.3.4.0
Using Ambari UI, I tried to start my NN. But, its showing below error.
safemode: Call From server1.ddns.net/141.178.0.16 to server1.ddns.net:8020 failed on connection exception: java.net.ConnectException: Connection refused; For more details see: http://wiki.apache.org/hadoop/ConnectionRefused 2016-06-03 12:40:06,640 - Retrying after 10 seconds. Reason: Execution of '/usr/hdp/current/hadoop-hdfs-namenode/bin/hdfs dfsadmin -fs hdfs://server1.ddns.net:8020 -safemode get | grep 'Safe mode is OFF'' returned 1. safemode: Call From server1.ddns.net/141.178.0.16 to server1.ddns.net:8020 failed on connection exception: java.net.ConnectException: Connection refused; For more details see: http://wiki.apache.org/hadoop/ConnectionRefused
After that, I tried below commands and the outputs are:
[root@server1 ~]# sudo -u hdfs hdfs dfsadmin -report report: Call From server1.ddns.net/141.178.0.16 to server1.ddns.net:8020 failed on connection exception: java.net.ConnectException: Connection refused; For more details see: http://wiki.apache.org/hadoop/ConnectionRefused [root@server1 ~]# sudo -u hdfs hdfs dfsadmin -safemode enter safemode: Call From server1.ddns.net/141.178.0.16 to server1.ddns.net:8020 failed on connection exception: java.net.ConnectException: Connection refused; For more details see: http://wiki.apache.org/hadoop/ConnectionRefused [root@server1 ~]# sudo -u hdfs hdfs dfsadmin -safemode leave safemode: Call From server1.ddns.net/141.178.0.16 to server1.ddns.net:8020 failed on connection exception: java.net.ConnectException: Connection refused; For more details see: http://wiki.apache.org/hadoop/ConnectionRefused [root@server1 ~]#
1) Why is it not leaving from safemode?
2) What could be the solution to resolve my problem and make the NN up?
Please help me in this regard....
Created 06-05-2016 10:24 AM
Ambari 2.2.1.0 and HDP 2.3.4.0
and this issue got resolved with below steps
1) stopped ambari agent and ambari server
2) did NN format using --> hdfs namenode -format
3) provided 777 rights and changed the user to hadoop, for namenode folder resided in the below path
/bigdata/hadoop/hdfs/namenode
4) restarted the agent and server.
Created 06-05-2016 10:36 AM
Not sure why NN format required here.
Created 05-22-2017 11:22 AM
@c pat....I couldnt find the namenode location...
Created 09-13-2017 08:47 PM
I did first two step but I got the same connection refused when I tried 777 rights
Created 10-23-2017 12:24 PM
Please Add this below lines to hdfs-site.xml in between configuration properties and restart the hdfs.
<property>
<name>dfs.safemode.threshold.pct</name>
<value>0</value>
</property>
Created 04-03-2018 09:18 PM
Thanks it works for me.
Created 10-10-2018 12:25 AM
Hello, I am facing the same error in my cluster, and same all above thing is reflecting, how did you solve this problem. waiting for your reply. please heal me out. @c pat