Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 01-23-2018 04:12 PM
Dear community,
I have very hard time installing HDP 2.6.4 on Centos 7.4. Would appreciate help.
I followed carefully the instructions at https://docs.hortonworks.com/HDPDocuments/Ambari-2.6.1.0/bk_ambari-installation/content/ch_Getting_R...
Before starting the wizard:
I installed & started MySql (using the instructions here: https://linode.com/docs/databases/mysql/how-to-install-mysql-on-centos-7/).
Installed (=extracted) mysql-connector-java-5.1.45.tar.gz to /usr/lib/
run: ambari-server setup --jdbc-db=mysql --jdbc-driver=/usr/lib/mysql-connector-java-5.1.45/mysql-connector-java-5.1.45-bin.jar
After starting the server, I followed the the wizard. At the "Install-start-test, "Hive Metastore Start" failes. The error it fails on is: http://hdptst5:8080/resources//mysql-connector-java.jar due to HTTP error: HTTP Error 404: Not Found
(Attached is the entire log)
Any help would be appreciated.
--yuval
Created 01-24-2018 05:04 PM
in addition to installing mysql-connector-java-5.1.45-bin, I added a link to it:
ln -s /usr/lib/mysql-connector-java-5.1.45/mysql-connector-java-5.1.45-bin.jar /usr/share/java/mysql-connector-java.jar
I already disable/stop firewalld as in the document. In addition, I stopped iptables (using: iptables -F). This is not in the doc. not sure if this helped or not.
I now have working environment. Thank you @Jay Kumar SenSharma & @Shyam Sunder Rai for your valuable comments.
Created 01-23-2018 04:20 PM
Created 01-23-2018 07:12 PM
@Yuval Smp Try disabling firewall and iptables, once you are through then rerun ambari-server setup --jdbc-db=mysql --jdbc-driver=/usr/lib/mysql-connector-java-5.1.45/mysql-connector-java-5.1.45-bin.jar. Track the ambari-server log to ensure that there are no error. Try again.
Created 01-23-2018 08:27 PM
Thanks @Shyam Sunder Rai.
Before starting the install, I followed the instructions and:
In addition I uninstalled PackageKit.
Anything else that I had to do ?
Created 01-24-2018 12:11 AM
Have you already done the following steps?
# yum install mysql-connection-java -y
(OR) if you are downloading the mysql-connector-java JAR from some tar.gz archive then please make sure to check the following locations and create the symlinks something like following to point to your jar.
.
Then you should find some symlink as following:
Example:
# ls -l /usr/share/java/mysql-connector-java.jar lrwxrwxrwx 1 root root 31 Apr 19 2017 /usr/share/java/mysql-connector-java.jar -> mysql-connector-java-5.1.17.jar
So now ambari knows how to find this jar. The JAR can be found here after
# ambari-server setup --jdbc-db=mysql --jdbc-driver=/usr/share/java/mysql-connector-java.jar # ls -l /var/lib/ambari-server/resources/mysql-connector-java.jar -rw-r--r-- 1 root root 819803 Sep 28 19:52 /var/lib/ambari-server/resources/mysql-connector-java.jar
.
Ambari Agents tries to download the mysql connector jar from ambari server using URL:
http://hdptst5:8080/resources/mysql-connector-java.jar
.
So you will need to make sure that the following path exist. Means there should be a symlink as following which points to the path of your downloaded JAR. "
# ls -l /var/lib/ambari-server/resources/my* -rw-r--r-- 1 root root 819803 Sep 28 19:52 /var/lib/ambari-server/resources/mysql-connector-java.jar lrwxrwxrwx 1 root root 57 May 26 2017 /var/lib/ambari-server/resources/mysql-jdbc-driver.jar -> /usr/lib/mysql-connector-java-5.1.45/mysql-connector-java-5.1.45-bin.jar
.
/var/lib/ambari-server/resources/mysql-jdbc-driver.jar -> /usr/lib/mysql-connector-java-5.1.45/mysql-connector-java-5.1.45-bin.jar
Created 01-24-2018 05:04 PM
in addition to installing mysql-connector-java-5.1.45-bin, I added a link to it:
ln -s /usr/lib/mysql-connector-java-5.1.45/mysql-connector-java-5.1.45-bin.jar /usr/share/java/mysql-connector-java.jar
I already disable/stop firewalld as in the document. In addition, I stopped iptables (using: iptables -F). This is not in the doc. not sure if this helped or not.
I now have working environment. Thank you @Jay Kumar SenSharma & @Shyam Sunder Rai for your valuable comments.