Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created on 05-29-2014 11:15 PM - edited 09-16-2022 01:59 AM
Hi
I have installed CDH5. I was able to install all services including oozie. But when I try to configure Oozie to use our mysql database, I am getting the following error :
SERVER[test.pldc.co.org] USER[-] GROUP[-] TOKEN[-] APP[-] JOB[-] ACTION[-] E0103: Could not load service classes, Cannot create PoolableConnectionFactory (Table 'oozie.VALIDATE_CONN' doesn't exist)
org.apache.oozie.service.ServiceException: E0103: Could not load service classes, Cannot create PoolableConnectionFactory (Table 'oozie.VALIDATE_CONN' doesn't exist
I am not sure if Cloudera Manager is supposed to create the database automatically in mysql after you enter the databasein information. But when I get this error, I created the database myself(db = oozie). But I am still getting this error.
Any help will be apprecaited.
Thanks
Ferds
Created 05-30-2014 08:11 AM
After changing Oozie's database (you need to create the mysql user and database outside of CM,), you need to run the appropriate command to populate that database with oozie's tables.
Click on Oozie, then in the Actions menu on the right, select Create Database. Oozie must be stopped to do this.
Created 05-30-2014 08:11 AM
After changing Oozie's database (you need to create the mysql user and database outside of CM,), you need to run the appropriate command to populate that database with oozie's tables.
Click on Oozie, then in the Actions menu on the right, select Create Database. Oozie must be stopped to do this.
Created 03-01-2015 03:42 AM
How to populate the oozie tables into the database. I'm using mysql instead of oozie.
Created 03-01-2015 06:35 AM
As dlo mentioned, you need to use "Create Database" from Cloudera Manager. You can also create it from the command line if not using Cloudera Manager. See the following for more information:
Ben