Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 03-31-2017 05:48 PM
1) Error
Traceback (most recent call last):
File "/var/lib/ambari-agent/cache/common-services/OOZIE/4.0.0.2.0/package/scripts/service_check.py", line 138, in <module>
OozieServiceCheck().execute()
File "/usr/lib/python2.6/site-packages/resource_management/libraries/script/script.py", line 219, in execute
method(env)
File "/var/lib/ambari-agent/cache/common-services/OOZIE/4.0.0.2.0/package/scripts/service_check.py", line 61, in service_check
OozieServiceCheckDefault.oozie_smoke_shell_file(smoke_test_file_name, prepare_hdfs_file_name)
File "/var/lib/ambari-agent/cache/common-services/OOZIE/4.0.0.2.0/package/scripts/service_check.py", line 123, in oozie_smoke_shell_file
logoutput=True
File "/usr/lib/python2.6/site-packages/resource_management/core/base.py", line 154, in __init__
self.env.run()
File "/usr/lib/python2.6/site-packages/resource_management/core/environment.py", line 160, in run
self.run_action(resource, action)
File "/usr/lib/python2.6/site-packages/resource_management/core/environment.py", line 124, in run_action
provider_action()
File "/usr/lib/python2.6/site-packages/resource_management/core/providers/system.py", line 238, in action_run
tries=self.resource.tries, try_sleep=self.resource.try_sleep)
File "/usr/lib/python2.6/site-packages/resource_management/core/shell.py", line 70, in inner
result = function(command, **kwargs)
File "/usr/lib/python2.6/site-packages/resource_management/core/shell.py", line 92, in checked_call
tries=tries, try_sleep=try_sleep)
File "/usr/lib/python2.6/site-packages/resource_management/core/shell.py", line 140, in _call_wrapper
result = _call(command, **kwargs_copy)
File "/usr/lib/python2.6/site-packages/resource_management/core/shell.py", line 291, in _call
raise Fail(err_msg)
resource_management.core.exceptions.Fail: Execution of '/var/lib/ambari-agent/tmp/oozieSmoke2.sh redhat /var/lib/oozie /etc/oozie/conf /usr/bin http://centos2.test.com:11000/oozie /usr/share/doc/oozie-4.0.0.2.1.10.0 /etc/hadoop/conf /usr/bin ambari-qa False' returned 1. source /etc/oozie/conf/oozie-env.sh ; /usr/bin/oozie -Doozie.auth.token.cache=false job -oozie http://centos2.test.com:11000/oozie -config /usr/share/doc/oozie-4.0.0.2.1.10.0/examples/apps/map-reduce/job.properties -run
SLF4J: Class path contains multiple SLF4J bindings.
SLF4J: Found binding in [jar:file:/usr/lib/oozie/lib/slf4j-log4j12-1.6.6.jar!/org/slf4j/impl/StaticLoggerBinder.class]
SLF4J: Found binding in [jar:file:/usr/lib/oozie/lib/slf4j-simple-1.6.6.jar!/org/slf4j/impl/StaticLoggerBinder.class]
SLF4J: See http://www.slf4j.org/codes.html#multiple_bindings for an explanation.
SLF4J: Actual binding is of type [org.slf4j.impl.Log4jLoggerFactory]
log4j:WARN No appenders could be found for logger (org.apache.hadoop.security.authentication.client.KerberosAuthenticator).
log4j:WARN Please initialize the log4j system properly.
log4j:WARN See http://logging.apache.org/log4j/1.2/faq.html#noconfig for more info.
Error: E0501 : E0501: Could not perform authorization operation, User: oozie is not allowed to impersonate ambari-qa
Invalid sub-command: Missing argument for option: info
use 'help [sub-command]' for help details
Invalid sub-command: Missing argument for option: info
use 'help [sub-command]' for help details
workflow_status=Error: E0501 : E0501: Could not perform authorization operation, User: oozie is not allowed to impersonate ambari-qa
2)Python script has been killed due to timeout after waiting 300 secs
3) File "/usr/lib/python2.6/site-packages/resource_management/core/shell.py", line 291, in _call
raise Fail(err_msg)
resource_management.core.exceptions.Fail: Execution of '/var/lib/ambari-agent/tmp/oozieSmoke2.sh redhat /var/lib/oozie /etc/oozie/conf /usr/bin http://centos2.test.com:11000/oozie /usr/share/doc/oozie-4.0.0.2.1.10.0 /etc/hadoop/conf /usr/bin ambari-qa False' returned 1. source /etc/oozie/conf/oozie-env.sh ; /usr/bin/oozie -Doozie.auth.token.cache=false job -oozie http://centos2.test.com:11000/oozie -config /usr/share/doc/oozie-4.0.0.2.1.10.0/examples/apps/map-reduce/job.properties -run
SLF4J: Class path contains multiple SLF4J bindings.
SLF4J: Found binding in [jar:file:/usr/lib/oozie/lib/slf4j-log4j12-1.6.6.jar!/org/slf4j/impl/StaticLoggerBinder.class]
SLF4J: Found binding in [jar:file:/usr/lib/oozie/lib/slf4j-simple-1.6.6.jar!/org/slf4j/impl/StaticLoggerBinder.class]
SLF4J: See http://www.slf4j.org/codes.html#multiple_bindings for an explanation.
SLF4J: Actual binding is of type [org.slf4j.impl.Log4jLoggerFactory]
log4j:WARN No appenders could be found for logger (org.apache.hadoop.security.authentication.client.KerberosAuthenticator).
log4j:WARN Please initialize the log4j system properly.
log4j:WARN See http://logging.apache.org/log4j/1.2/faq.html#noconfig for more info.
Job ID : 0000023-170331225332898-oozie-oozi-W
-----------------------------------------------------
Created 04-01-2017 01:03 PM
Solution for Given Error, still 3 Ans not able to get.
1st Error :-
Error: E0501 : E0501: Could not perform authorization operation, User: oozie is not allowed to impersonate ambari-qa Invalid sub-command: Missing argument for option: info
Solution :-
<property>
<name>hadoop.proxyuser.oozie.groups</name>
<value>*</value>
</property>
<property>
<name>hadoop.proxyuser.oozie.hosts</name>
<value></value>
</property>
<property>
<name>hadoop.proxyuser.oozie.users</name>
<value>*</value>
</property>
2nd Error :-
Error :- Python script has been killed due to timeout after waiting 300 secs
Solution:- on ambari-server changed the following parameter
Increased the time 300 to 900 seconds mine OOZIE version is 4.0.0.2.0
[ambari-qa@centos root]$ oozie version
Oozie client build version: 4.0.0.2.1.10.0-881
[ambari-qa@centos root]$
[root@centos ~]# grep 300 /var/lib/ambari-server/resources/common-services/OOZIE/4.0.0.2.0/metainfo.xml
<timeout>300</timeout>
[root@centos ~]#3rd Error:-
resource_management.core.exceptions.Fail: Execution of '/var/lib/ambari-agent/tmp/oozieSmoke2.sh redhat /var/lib/oozie /etc/oozie/conf /usr/bin http://centos2.test.com:11000/oozie /usr/share/doc/oozie-4.0.0.2.1.10.0 /etc/hadoop/conf /usr/bin ambari-qa False' returned 1. source /etc/oozie/conf/oozie-env.sh ; /usr/bin/oozie -Doozie.auth.token.cache=false job -oozie http://centos2.test.com:11000/oozie -config /usr/share/doc/oozie-4.0.0.2.1.10.0/examples/apps/map-reduce/job.properties -run SLF4J: Class path contains multiple SLF4J bindings.
Error:- resource_management.core.exceptions.Fail: Execution of '/var/lib/ambari-agent/tmp/oozieSmoke2.sh redhat /var/lib/oozie /etc/oozie/conf /usr/bin http://centos2.test.com:11000/oozie /usr/share/doc/oozie-4.0.0.2.1.10.0 /etc/hadoop/conf /usr/bin ambari-qa False' returned 1. source /etc/oozie/conf/oozie-env.sh ; /usr/bin/oozie -Doozie.auth.token.cache=false job -oozie http://centos2.test.com:11000/oozie -config /usr/share/doc/oozie-4.0.0.2.1.10.0/examples/apps/map-reduce/job.properties -run SLF4J: Class path contains multiple SLF4J bindings. SLF4J: Found binding in [jar:file:/usr/lib/oozie/lib/slf4j-log4j12-1.6.6.jar!/org/slf4j/impl/StaticLoggerBinder.class] SLF4J: Found binding in [jar:file:/usr/lib/oozie/lib/slf4j-simple-1.6.6.jar!/org/slf4j/impl/StaticLoggerBinder.class] SLF4J: See http://www.slf4j.org/codes.html#multiple_bindings for an explanation. SLF4J: Actual binding is of type [org.slf4j.impl.Log4jLoggerFactory] log4j:WARN No appenders could be found for logger (org.apache.hadoop.security.authentication.client.KerberosAuthenticator). log4j:WARN Please initialize the log4j system properly. log4j:WARN See http://logging.apache.org/log4j/1.2/faq.html#noconfig for more info. Job ID : 0000026-170331225332898-oozie-oozi-W ------------------------------------------------------------------------------------------------------------------------------------ Workflow Name : map-reduce-wf App Path : hdfs://centos4.test.com:8020/user/ambari-qa/examples/apps/map-reduce Status : RUNNING Run : 0 User : ambari-qa Group : - Created : 2017-03-31 21:50 GMT Started : 2017-03-31 21:50 GMT Last Modified : 2017-03-31 21:50 GMT Ended : - CoordAction ID: - Actions ------------------------------------------------------------------------------------------------------------------------------------ ID Status Ext ID Ext Status Err Code ------------------------------------------------------------------------------------------------------------------------------------ 0000026-170331225332898-oozie-oozi-W@mr-node PREP - - - ------------------------------------------------------------------------------------------------------------------------------------ 0000026-170331225332898-oozie-oozi-W@:start: OK - OK - ------------------------------------------------------------------------------------------------------------------------------------ Job ID : 0000026-170331225332898-oozie-oozi-W ------------------------------------------------------------------------------------------------------------------------------------ Workflow Name : map-reduce-wf App Path : hdfs://centos4.test.com:8020/user/ambari-qa/examples/apps/map-reduce Status : RUNNING Run : 0 User : ambari-qa Group : - Created : 2017-03-31 21:50 GMT Started : 2017-03-31 21:50 GMT Last Modified : 2017-03-31 21:50 GMT Ended : - CoordAction ID: -
Created 03-31-2017 05:50 PM
Error: E0501 : E0501: Could not perform authorization operation, User: oozie is not allowed to impersonate ambari-qa
Created 03-31-2017 06:02 PM
Do you have following entries in your core-site.xml?
<property>
<name>hadoop.proxyuser.oozie.groups</name>
<value>*</value>
</property>
<property>
<name>hadoop.proxyuser.oozie.hosts</name>
<value>*</value>
</property>
<property>
<name>hadoop.proxyuser.oozie.users</name>
<value>*</value>
</property>
.
Created 04-01-2017 04:25 AM
thanks for your reply its worked fine and after setting getting error as
1)Python script has been killed due to timeout after waiting 300 secs
2) File "/usr/lib/python2.6/site-packages/resource_management/core/shell.py", line 140, in _call_wrapper
result = _call(command, **kwargs_copy)
File "/usr/lib/python2.6/site-packages/resource_management/core/shell.py", line 291, in _call
raise Fail(err_msg)
resource_management.core.exceptions.Fail: Execution of '/var/lib/ambari-agent/tmp/oozieSmoke2.sh redhat /var/lib/oozie /etc/oozie/conf /usr/bin http://centos2.test.com:11000/oozie /usr/share/doc/oozie-4.0.0.2.1.10.0 /etc/hadoop/conf /usr/bin ambari-qa False' returned 1. source /etc/oozie/conf/oozie-env.sh ; /usr/bin/oozie -Doozie.auth.token.cache=false job -oozie http://centos2.test.com:11000/oozie -config /usr/share/doc/oozie-4.0.0.2.1.10.0/examples/apps/map-reduce/job.properties -run
SLF4J: Class path contains multiple SLF4J bindings.
Created 04-01-2017 01:03 PM
Solution for Given Error, still 3 Ans not able to get.
1st Error :-
Error: E0501 : E0501: Could not perform authorization operation, User: oozie is not allowed to impersonate ambari-qa Invalid sub-command: Missing argument for option: info
Solution :-
<property>
<name>hadoop.proxyuser.oozie.groups</name>
<value>*</value>
</property>
<property>
<name>hadoop.proxyuser.oozie.hosts</name>
<value></value>
</property>
<property>
<name>hadoop.proxyuser.oozie.users</name>
<value>*</value>
</property>
2nd Error :-
Error :- Python script has been killed due to timeout after waiting 300 secs
Solution:- on ambari-server changed the following parameter
Increased the time 300 to 900 seconds mine OOZIE version is 4.0.0.2.0
[ambari-qa@centos root]$ oozie version
Oozie client build version: 4.0.0.2.1.10.0-881
[ambari-qa@centos root]$
[root@centos ~]# grep 300 /var/lib/ambari-server/resources/common-services/OOZIE/4.0.0.2.0/metainfo.xml
<timeout>300</timeout>
[root@centos ~]#3rd Error:-
resource_management.core.exceptions.Fail: Execution of '/var/lib/ambari-agent/tmp/oozieSmoke2.sh redhat /var/lib/oozie /etc/oozie/conf /usr/bin http://centos2.test.com:11000/oozie /usr/share/doc/oozie-4.0.0.2.1.10.0 /etc/hadoop/conf /usr/bin ambari-qa False' returned 1. source /etc/oozie/conf/oozie-env.sh ; /usr/bin/oozie -Doozie.auth.token.cache=false job -oozie http://centos2.test.com:11000/oozie -config /usr/share/doc/oozie-4.0.0.2.1.10.0/examples/apps/map-reduce/job.properties -run SLF4J: Class path contains multiple SLF4J bindings.
Error:- resource_management.core.exceptions.Fail: Execution of '/var/lib/ambari-agent/tmp/oozieSmoke2.sh redhat /var/lib/oozie /etc/oozie/conf /usr/bin http://centos2.test.com:11000/oozie /usr/share/doc/oozie-4.0.0.2.1.10.0 /etc/hadoop/conf /usr/bin ambari-qa False' returned 1. source /etc/oozie/conf/oozie-env.sh ; /usr/bin/oozie -Doozie.auth.token.cache=false job -oozie http://centos2.test.com:11000/oozie -config /usr/share/doc/oozie-4.0.0.2.1.10.0/examples/apps/map-reduce/job.properties -run SLF4J: Class path contains multiple SLF4J bindings. SLF4J: Found binding in [jar:file:/usr/lib/oozie/lib/slf4j-log4j12-1.6.6.jar!/org/slf4j/impl/StaticLoggerBinder.class] SLF4J: Found binding in [jar:file:/usr/lib/oozie/lib/slf4j-simple-1.6.6.jar!/org/slf4j/impl/StaticLoggerBinder.class] SLF4J: See http://www.slf4j.org/codes.html#multiple_bindings for an explanation. SLF4J: Actual binding is of type [org.slf4j.impl.Log4jLoggerFactory] log4j:WARN No appenders could be found for logger (org.apache.hadoop.security.authentication.client.KerberosAuthenticator). log4j:WARN Please initialize the log4j system properly. log4j:WARN See http://logging.apache.org/log4j/1.2/faq.html#noconfig for more info. Job ID : 0000026-170331225332898-oozie-oozi-W ------------------------------------------------------------------------------------------------------------------------------------ Workflow Name : map-reduce-wf App Path : hdfs://centos4.test.com:8020/user/ambari-qa/examples/apps/map-reduce Status : RUNNING Run : 0 User : ambari-qa Group : - Created : 2017-03-31 21:50 GMT Started : 2017-03-31 21:50 GMT Last Modified : 2017-03-31 21:50 GMT Ended : - CoordAction ID: - Actions ------------------------------------------------------------------------------------------------------------------------------------ ID Status Ext ID Ext Status Err Code ------------------------------------------------------------------------------------------------------------------------------------ 0000026-170331225332898-oozie-oozi-W@mr-node PREP - - - ------------------------------------------------------------------------------------------------------------------------------------ 0000026-170331225332898-oozie-oozi-W@:start: OK - OK - ------------------------------------------------------------------------------------------------------------------------------------ Job ID : 0000026-170331225332898-oozie-oozi-W ------------------------------------------------------------------------------------------------------------------------------------ Workflow Name : map-reduce-wf App Path : hdfs://centos4.test.com:8020/user/ambari-qa/examples/apps/map-reduce Status : RUNNING Run : 0 User : ambari-qa Group : - Created : 2017-03-31 21:50 GMT Started : 2017-03-31 21:50 GMT Last Modified : 2017-03-31 21:50 GMT Ended : - CoordAction ID: -