Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Archives of Support Questions (Read Only)

This is an archived board for historical reference. Information and links may no longer be available or relevant
Announcements
This board is archived and read-only for historical reference. To ask a new question, please post a new topic on the appropriate active board.

Oozie server failed to start with NoClassDefFoundError

avatar
New Member

Hi Team,

I am facing this issue while adding Oozie to an existing cluster, Oozie server start is failing with NoClassDefFoundError: org/apache/oozie/cli/CLIParser. Posting the stacktrace below. Kindly let me know how can I resolve this.

setting OOZIE_CONFIG=${OOZIE_CONFIG:-/usr/hdp/current/oozie-server/conf}
  setting CATALINA_BASE=${CATALINA_BASE:-/usr/hdp/current/oozie-server/oozie-server}
  setting CATALINA_TMPDIR=${CATALINA_TMPDIR:-/var/tmp/oozie}
  setting OOZIE_CATALINA_HOME=/usr/lib/bigtop-tomcat
  setting JAVA_HOME=/usr/jdk64/jdk1.8.0_60
  setting JRE_HOME=${JAVA_HOME}
  setting CATALINA_OPTS="$CATALINA_OPTS -Xmx2048m"
  setting OOZIE_LOG=/grid/0/log/oozie
  setting CATALINA_PID=/var/run/oozie/oozie.pid
  setting OOZIE_DATA=/grid/0/hadoop/oozie/data
  setting OOZIE_HTTP_PORT=11000
  setting OOZIE_ADMIN_PORT=11001
  setting JAVA_LIBRARY_PATH=/usr/hdp/current/hadoop-client/lib/native/Linux-amd64-64
  setting OOZIE_CLIENT_OPTS="${OOZIE_CLIENT_OPTS} -Doozie.connection.retry.count=5 "
  setting OOZIE_CONFIG=${OOZIE_CONFIG:-/usr/hdp/current/oozie-server/conf}
  setting CATALINA_BASE=${CATALINA_BASE:-/usr/hdp/current/oozie-server/oozie-server}
  setting CATALINA_TMPDIR=${CATALINA_TMPDIR:-/var/tmp/oozie}
  setting OOZIE_CATALINA_HOME=/usr/lib/bigtop-tomcat
  setting JAVA_HOME=/usr/jdk64/jdk1.8.0_60
  setting JRE_HOME=${JAVA_HOME}
  setting CATALINA_OPTS="$CATALINA_OPTS -Xmx2048m"
  setting OOZIE_LOG=/grid/0/log/oozie
  setting CATALINA_PID=/var/run/oozie/oozie.pid
  setting OOZIE_DATA=/grid/0/hadoop/oozie/data
  setting OOZIE_HTTP_PORT=11000
  setting OOZIE_ADMIN_PORT=11001
  setting JAVA_LIBRARY_PATH=/usr/hdp/current/hadoop-client/lib/native/Linux-amd64-64
  setting OOZIE_CLIENT_OPTS="${OOZIE_CLIENT_OPTS} -Doozie.connection.retry.count=5 "
Exception in thread "main" java.lang.NoClassDefFoundError: org/apache/oozie/cli/CLIParser
	at org.apache.oozie.tools.OozieSharelibCLI.run(OozieSharelibCLI.java:92)
	at org.apache.oozie.tools.OozieSharelibCLI.main(OozieSharelibCLI.java:67)
Caused by: java.lang.ClassNotFoundException: org.apache.oozie.cli.CLIParser
	at java.net.URLClassLoader.findClass(URLClassLoader.java:381)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
	at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:331)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
	... 2 more

Thanks,

Kishor

1 ACCEPTED SOLUTION

avatar
New Member

When Oozie server is starting , it is unable to find oozie-client-<version>.jar.

On my cluster I found it at /<HDP folder>/oozie-client-<version>.jar

That jar may have gotten deleted on your machine for some reason.

Please let me know if this helps. Thanks

View solution in original post

2 REPLIES 2

avatar
New Member

When Oozie server is starting , it is unable to find oozie-client-<version>.jar.

On my cluster I found it at /<HDP folder>/oozie-client-<version>.jar

That jar may have gotten deleted on your machine for some reason.

Please let me know if this helps. Thanks

avatar
New Member

Looks like we did some mistake while doing rpm cleanup. Copied oozie client jar to /usr/hdp/<version>/oozie/lib/ and it worked fine.

Thanks!