Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 02-23-2016 03:51 PM
I am trying to add two more hosts to my existing cluster (only has one right now) but I am running into errors during the Ambari step - Confirm Hosts. The error message is shown below. It says it failed because it finished with a non zero exit code. What does this mean and how can I fix it? I have followed the steps to configure passwordless ssh but I may have done something incorrectly. I have replace the host name with a bunch of x's.
========================== Creating target directory... ========================== Command start time 2016-02-23 10:45:50 Permission denied (publickey,gssapi-keyex,gssapi-with-mic,password). SSH command execution finished host=xxxxxxxxxxxxxxxxxxxxx, exitcode=255 Command end time 2016-02-23 10:45:51 ERROR: Bootstrap of host xxxxxxxxxxxxxxxxxxxx fails because previous action finished with non-zero exit code (255) ERROR MESSAGE: Permission denied (publickey,gssapi-keyex,gssapi-with-mic,password). STDOUT: Permission denied (publickey,gssapi-keyex,gssapi-with-mic,password).
Created 02-23-2016 03:58 PM
This is related to your ssh keys
Make sure that you test this
ssh localhost
if it asks for password then
cd ~/.ssh
cat id_rsa.pub >> authorized_keys
ssh localhost
Created 02-24-2016 01:13 PM
DNS has been configured but I still got an error message. One of the nodes I got the initial error I posted and the other I got the second error. What do you mean by leverage the /etc/hosts? @Neeraj Sabharwal
Created 02-24-2016 01:19 PM
Make sure that you modify the ambari.ini for agents to point to correct ambari server. Link
/etc/ambari-agent/conf/ambari-agent.ini has ambari server address
Created 02-24-2016 01:26 PM
Alright sounds good. Just to confirm the hostname I should enter would be the server Ambari is running on? Also would the hostname be the FQDN or the DNS name of the server? @Neeraj Sabharwal
Created 02-24-2016 01:49 PM
I had success during the "confirm hosts" stage for one of the servers. During the install I received the attached error message stating it requires fuse but I am unsure what this is. @Neeraj Sabharwal
Created 02-24-2016 03:28 PM
I retried the install and the error message did not appear this time. I was able to set up one of the two new servers with a couple warnings.
I tried to manually install the other server the same way but am getting a blank error message just stating the registration failed. When I look at the repolist something doesn't seem right here. It doesn't look like the table shown in the reference guide. @Neeraj Sabharwal
Registering with the server... Registration with the server failed.
Created 02-24-2016 03:55 PM
@Mark Thorson Let me confirm
1) You are installing ambari server in one of the nodes
2) You are manually installing agent in all the nodes
I won't worry about table yet.
You should go ahead and do the install
yum install ambari-server
and yum install ambari-agent --> in all nodes
Created on 02-24-2016 04:37 PM - edited 08-18-2019 05:32 AM
@Neeraj Sabharwal Yeah that is correct. I have installed Ambari Server on 1 node and Ambari Agent on all 3. The image below is the 3rd server. When I attempt to perform manual registration for this server I get an error message saying the code below.
Registering with the server... Registration with the server failed.
Created 02-24-2016 04:42 PM
@Mark Thorson Good news!!! 🙂 We have agent there already
modify ini file and add ambar server address then ambari-server start
Created on 02-24-2016 06:00 PM - edited 08-18-2019 05:32 AM
@Neeraj Sabharwal To confirm you mean the ini file on the machine running Ambari Server? I previously had the 3 servers listed in the ini file. Does Ambari Server require a restart after they have been added?
Created 02-24-2016 11:19 PM
@Mark Thorson /etc/ambari-agent/conf/ambari-agent.ini
The ini file in 3rd server.
What step are you on now?