Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 04-20-2016 10:35 AM
Hi
As per tutorial http://hortonworks.com/hadoop-tutorial/hands-on-tour-of-apache-spark-in-5-minutes/ I am able to run %sh interpreter and download Hortonworks data from wikipedia, however while trying to copy data to /tmp folder using following command as suggested in tutorial,
%sh hadoop fs -put ~/Hortonworks /tmp
zeppelin gives error as Process exited with an error: 1 (Exit value: 1).
Can anyone please suggest the workaround?
Thanks in advance.
Created 05-02-2016 09:01 PM
I tried the tutorial you referenced. I found that if I ran "%sh hadoop fs -put ~/Hortonworks /tmp" twice:
first time = successfully populated /tmp/Hortonworks
second time = failed with "Process exited with an error: 1 (Exit value: 1)" because /tmp/Hortonworks was already populated.
If I delete the /tmp/Hortonworks folder "%sh hadoop fs -rm -r -f /tmp/Hortonworks" , I am able to re-run "%sh hadoop fs -put ~/Hortonworks /tmp" successfully
Created 05-02-2016 09:01 PM
I tried the tutorial you referenced. I found that if I ran "%sh hadoop fs -put ~/Hortonworks /tmp" twice:
first time = successfully populated /tmp/Hortonworks
second time = failed with "Process exited with an error: 1 (Exit value: 1)" because /tmp/Hortonworks was already populated.
If I delete the /tmp/Hortonworks folder "%sh hadoop fs -rm -r -f /tmp/Hortonworks" , I am able to re-run "%sh hadoop fs -put ~/Hortonworks /tmp" successfully
Created 05-31-2016 10:26 AM
Thank you @Ryan Cicak It worked for me too now as I deleted the folder and again downloaded as you suggested.
Created 05-17-2016 08:39 PM
hello everybody
did you solve the problem ? i have this problem. can anyone help me?
i run ambari 2.2.1.0 and in zeppelin in interpreter tab %sh has no property , just like the situation of the first post.
Created 05-31-2016 10:29 AM
Ryan's suggested solution worked for me. However, I am still having no properties set for %sh interpreter.