Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 02-11-2016 06:20 AM
I'm trying to set up a single-node Hadoop cluster (HDP2.3 version) using Ambari 2.2 in Eucalyptus environment.
I have used Private IP address as recommended while registering the VM's (RHEL 6.5) with Ambari.
When I tried to bring up Hadoop services (MR2, Hive, Yarn) , I'm getting the below error:
<LI id=L_11001_11>Error Code 11001: Host not found <LI id=L_11001_12>Background: This error indicates that the gateway could not find the IP address of the website you are trying to access. This is usually due to a DNS-related error. <LI id=L_11001_13>Date: 2/9/2016 5:57:11 AM [GMT] <LI id=L_11001_14>Server: FIESPRX004.xxx.net <LI id=L_11001_15>Source: DNS error </UL>
Created 02-11-2016 10:43 AM
@Phoncy Joseph Are you getting this error in the browser?
Take a look on this thread http://hammadk.com/explanation-the-ip-address-for-the-website-you-requested-could-not-be-found/
Created 02-11-2016 07:10 AM
Please have a look at dns configuration for Eucalyptus
Created 02-11-2016 10:43 AM
@Phoncy Joseph Are you getting this error in the browser?
Take a look on this thread http://hammadk.com/explanation-the-ip-address-for-the-website-you-requested-could-not-be-found/
Created 02-11-2016 11:03 AM
Thanks for the response. I have set no proxy for local addresses in the host machine using export no_proxy from the command line. Below is the command that fails while starting the service:
resource_management.core.exceptions.Fail: Execution of 'curl -sS -L -w '%{http_code}' -X GET 'http://fqdn:50070/webhdfs/v1/app-logs?op=GETFILESTATUS&user.name=hdfs'' returned status_code=502.
Created 02-11-2016 11:07 AM
@Phoncy Joseph Bad Gateway request. Are you able to run this? telnet fqdn 50070 ?
Created 02-11-2016 11:11 AM
Yes, it says connected.
Created 02-11-2016 11:19 AM
@Phoncy Joseph Let's check if this shed more light http://www.cyberciti.biz/faq/linux-unix-set-proxy-environment-variable/
Created 02-11-2016 11:53 AM
Setting no proxy for the fqdn in /etc/profile solved the issue. Thanks.
Created 02-11-2016 12:28 PM
Please accept one of the answers to close the thread.
Created 02-11-2016 11:19 AM
what is your JDK version with Ambari 2.2? I'm wondering if you're hitting this https://issues.apache.org/jira/browse/AMBARI-14778 @Phoncy Joseph