Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Archives of Support Questions (Read Only)

This is an archived board for historical reference. Information and links may no longer be available or relevant
Announcements
This board is archived and read-only for historical reference. To ask a new question, please post a new topic on the appropriate active board.

PutSQL with errors

avatar
Master Guru

I have 60,000 flow files in a PutSQL processor and I know the SQL is invalid and it is failing in chunks and waiting 1 second and moving through. I was able to empty out all the backed up queues, but this processor is slowly parsing these failed files.

I want to purge them out, how can I do this? It's a waste to wait knowing all these will fail.

1 ACCEPTED SOLUTION

avatar

The easiest way is to stop NiFi, delete all files in the content and flowfile repositories, then restart NiFi.

View solution in original post

1 REPLY 1

avatar

The easiest way is to stop NiFi, delete all files in the content and flowfile repositories, then restart NiFi.