Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 01-27-2016 08:57 AM
I am seeing the following when it is trying to install Ranger Admin on the Ranger host server:
2016-01-27 08:48:59,962 [I] Database ranger already exists. 2016-01-27 08:48:59,962 [I] ---------- Granting permission to Ranger Admin db user ---------- 2016-01-27 08:48:59,962 [I] ---------- Granting privileges TO user 'rangeradmin'@'%' on db 'ranger'---------- SQLException : SQL state: 42000 com.mysql.jdbc.exceptions.jdbc4.MySQLSyntaxErrorException: Access denied for user 'root'@'hostname' to database 'ranger' ErrorCode: 1044 SQLException : SQL state: 42000 com.mysql.jdbc.exceptions.jdbc4.MySQLSyntaxErrorException: Access denied for user 'root'@'hostname' to database 'ranger' ErrorCode: 1044 2016-01-27 08:49:00,520 [E] Granting privileges to 'rangeradmin' failed on 'ranger'
I have logged onto MySQL on the host machine and granted the following privileges and still the installation throws Access Denied error.
Created 01-27-2016 11:21 AM
Try this
grant all privileges on *.* to 'root'@'host' identified by 'password' with grant option;
then restart/reinstall rangeradmin process
Created 03-20-2018 09:28 AM
I am having this error as well,
where should I gran this permissions on the local terminal or inside the hdp?
and what is the command?
thanks for your help.
Created 03-29-2018 11:54 AM
Try this
grant all privileges on *.* to 'root'@'host' identified by 'password' with grant option;
Created 07-03-2018 10:01 AM
Hi,
We was facing same issue.We tried some resolution
First we tried:
grant all privileges on *.* to 'root'@'hadoop04' identified by 'password';
again we was facing same issue
SQLException : SQL state: 42000 com.mysql.jdbc.exceptions.jdbc4.MySQLSyntaxErrorException: Access denied for user 'root'@'hadoop04' to database 'ranger' ErrorCode: 1044 2018-07-03 15:13:50,524 [E] Granting privileges to 'rangeradmin' failed on 'ranger'
we had tried with IP address
grant all privileges on *.* to 'root'@'ip_address_of_rangerhost' identified by 'password';
Which works for me.
Regards
Vinay K