Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 12-21-2017 05:10 PM
Hi,
this is a HDP 2.6.2.14-5 deployment using Ambari 2.5.2 with enabled Kerberos.
I've successfully installed Ambari-Infra service and, after installing Ranger, the access audit is showing this error:
HTTP ERROR 404 Problem accessing /solr/ranger_audits/select. Reason: Not found
This is the configuration in ranger.audit.solr.urls:
http://<fqdn>:8886/solr/ranger_audits
Many thanks in advance,
Jorge.
Created 01-31-2018 10:22 AM
Hi Youngick, try enabling SolrCloud. That solved the issue for me.
Created 12-22-2017 04:52 AM
Jorge Florencio is this Error you are seeing coming while accessing the audits from ranger UI ?
Created 01-31-2018 09:58 AM
Hi Deepak,
now it's working, after enabling SolrCloud.
Thank you,
Jorge.
Created 01-31-2018 10:16 AM
A few days ago, I have suffered from exactly same issue. ZK, Solr, Ranger all restarted but there is no collection. Anybody knows the solution?
Created 01-31-2018 10:22 AM
Hi Youngick, try enabling SolrCloud. That solved the issue for me.
Created 01-31-2018 10:40 AM
SolrCloud already enabled. Sometimes rager_audit collection created, but not for me.
Created 09-21-2018 09:13 PM
+1 on enabling SolrCloud. (Ambari -> Ranger -> Configs -> Ranger Audit -> Audit to SolrCloud: ON)
Created 05-28-2020 12:55 AM
Works for me.
+1 on enabling SolrCloud. (Ambari -> Ranger -> Configs -> Ranger Audit -> Audit to SolrCloud: ON)