Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Archives of Support Questions (Read Only)

This is an archived board for historical reference. Information and links may no longer be available or relevant
Announcements
This board is archived and read-only for historical reference. To ask a new question, please post a new topic on the appropriate active board.

Ranger installation failed

avatar
Super Collaborator

I was trying to configure Ranger, however installation failed with message 'java.sql.sqlexception: Access denied for user 'root'@'hiveserver' using password:YES.

ranger-error.png

Note: Am able to login to mysql 'mysql -u root -p' with default password 'hadoop'.

Kindly can some one assist me with the error am facing with Ranger installation.

1 ACCEPTED SOLUTION

avatar

can you run these commands on your mysql database and retry:

GRANT ALL ON *.* TO 'root'@'hiveserver' IDENTIFIED BY 'hadoop' WITH GRANT OPTION;

flush privileges;

View solution in original post

2 REPLIES 2

avatar

can you run these commands on your mysql database and retry:

GRANT ALL ON *.* TO 'root'@'hiveserver' IDENTIFIED BY 'hadoop' WITH GRANT OPTION;

flush privileges;

avatar
Super Collaborator

I have created new set of User with correct hostname and privileges and it worked, thankyou