Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created on 10-04-2018 01:34 AM - edited 09-16-2022 06:46 AM
Hi,
I am facing the same issue.
I tried with both users: root and cloudera-scm to set as owners for /var/hdfs-sockets/dn.
Error is: Address already in use when trying to bind to '/var/hdfs-sockets/dn'
But without success.
Can someone please provide some hints on this?
Thanks
Created 10-06-2018 01:46 PM
Hi,
solution is that in /var/hdfs-sockets/dn dn should not be created as directory.
dn will be created automatically as a file.
My mistake was becase I created dn also as directory and that is why I was getting an error.
Thank you for assitance
Created 10-04-2018 11:07 AM
I moved this post in front of the HDFS community members since it targets problem with HDFS rather than CM itself.
Can you provide the actions you took and evidence of what happened (provide logs and/or screenshots?)
Thanks!
Created 10-04-2018 11:10 PM
@VeljkoC Are you using cloudera manager?
If yes, can you check the hdfs configuration for UNIX Domain Socket path, what is it value?
If it empty try to add : /hadoop/sockets/hdfs-sockets/dn
Created 10-06-2018 01:46 PM
Hi,
solution is that in /var/hdfs-sockets/dn dn should not be created as directory.
dn will be created automatically as a file.
My mistake was becase I created dn also as directory and that is why I was getting an error.
Thank you for assitance