Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 04-30-2016 04:11 PM
I am trying to register a host with my Ambari server. I am using ubuntu, and the version of the server is 2.2.1.0-161
but when trying to register the host, it fails with this error in bootstrap error:
INFO:root:BootStrapping hosts ['salvob2'] using /usr/lib/python2.6/site-packages/ambari_server cluster primary OS: ubuntu16 with user 'root' sshKey File /var/run/ambari-server/bootstrap/1/sshKey password File null using tmp dir /var/run/ambari-server/bootstrap/1 ambari: salvob1; server_port: 8080; ambari version: 2.2.1.0; user_run_as: root INFO:root:Executing parallel bootstrap ERROR:root:ERROR: Bootstrap of host salvob2 fails because previous action finished with non-zero exit code (1) ERROR MESSAGE: Connection to salvob2 closed. STDOUT: Desired version (2.2.1.0) of ambari-agent package is not available. Repository has following versions of ambari-agent:2.2.1.0,2.2.1.0, Connection to salvob2 closed. INFO:root:Finished parallel bootstrap
Created 04-30-2016 05:14 PM
As a quick workaround, you can do a manual registration of ambari-agent. Steps are here
This should let your proceed with ambari-agent registration.
Created 04-30-2016 05:14 PM
As a quick workaround, you can do a manual registration of ambari-agent. Steps are here
This should let your proceed with ambari-agent registration.
Created 04-30-2016 11:48 PM
Thank you for the reply. I did some research and it is important to add the right repo.list
This is a "better" guide .
Plus, I was installing ambari in my Lubuntu 16.04 . I was sure it was fully compatible and almost the same with a 14.04 Ubuntu version. But I found out that it fails in registering a host with a "not-recognised os", here the stack error log from /var/log/ambari-agent/ambari-agent.log :
INFO 2016-05-01 01:01:03,673 NetUtil.py:60 - Connecting to https://salvob1:8440/connection_info INFO 2016-05-01 01:01:04,165 security.py:99 - SSL Connect being called.. connecting to the server INFO 2016-05-01 01:01:04,792 security.py:60 - SSL connection established. Two-way SSL authentication is turned off on the server. ERROR 2016-05-01 01:01:05,197 Controller.py:165 - Cannot register host with not supported os type, hostname=salvob2, serverOsType=ubuntu16, agentOsType=ubuntu16 INFO 2016-05-01 01:01:05,199 Controller.py:394 - Registration response from salvob1 was FAILED
I hope Hortonworks add soon, even a small support to this new os
Created 05-01-2016 12:11 AM
Yes, ubuntu16 is the problem here. As indicated on the other thread, support for this is going to take some time. Is this a production setup or testing one? If so, you can try with ubuntu14?