Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created on
07-26-2018
07:41 PM
- last edited on
04-21-2026
05:15 AM
by
GrazittiAPI
I am in the process of deploying my first HDP, and HDF combined cluster. I installed HDP 2.6.5 in a 5 nodes environment, and trying to install HDF mpack on top of it.
However, I accidentally installed wrong version of the HDF mpack, and wondering if there is a way I can remove it and re-install the correct HDF mpack.
Thanks in advance!
Paul
Created 07-26-2018 08:10 PM
@Paul Lam I ran into the same issue in the past. Basically you will need to stop the Amberi server, then use a hidden command to remove the mpack, then reinstall the proper HDF mpack.
Here are the steps I took to get it resolved:
step1: ambari-server stop
step2: ambari-server uninstall-mpack --mpack-name=hdf-ambari-mpack --verbose
step3: ambari-server install-mpack --mpack=hdf-ambari-mpack-<version>.tar.gz --verbose
step4: ambari-server start
Please accept the answer if it helped. Thanks.
Created 07-26-2018 07:53 PM
Please review this HCC link instructions:
you will find the command to remove the mpack installed
ambari-server uninstall-mpack --mpack-name=hdf-ambari-mpack --verbose
HTH
*** If you found this answer addressed your question, please take a moment to login and click the "accept" link on the answer.
Created 07-26-2018 08:10 PM
@Paul Lam I ran into the same issue in the past. Basically you will need to stop the Amberi server, then use a hidden command to remove the mpack, then reinstall the proper HDF mpack.
Here are the steps I took to get it resolved:
step1: ambari-server stop
step2: ambari-server uninstall-mpack --mpack-name=hdf-ambari-mpack --verbose
step3: ambari-server install-mpack --mpack=hdf-ambari-mpack-<version>.tar.gz --verbose
step4: ambari-server start
Please accept the answer if it helped. Thanks.
Created 07-26-2018 11:16 PM
I follow those four steps, and it worked. Thanks again.
Created 12-09-2019 03:45 AM
Post reinstalling HDF mpack getting below error :
ERROR: Failed to execute after-install hook. Failed with error code after-install
ERROR: Traceback (most recent call last):
File "/var/lib/ambari-server/resources/mpacks/hdf-ambari-mpack-3.4.1.1-4/hooks/after_install.py", line 36, in <module>
smartsense_versioner.fix_smartsense_versions()
File "/var/lib/ambari-server/resources/mpacks/hdf-ambari-mpack-3.4.1.1-4/hooks/smartsense_versioner.py", line 58, in fix_smartsense_versions
shell.checked_call(["cp", "-f", source_view_jar_file_path, new_view_jar_file_path], sudo=True)
File "/usr/lib/ambari-server/lib/resource_management/core/shell.py", line 72, in inner
result = function(command, **kwargs)
File "/usr/lib/ambari-server/lib/resource_management/core/shell.py", line 102, in checked_call
tries=tries, try_sleep=try_sleep, timeout_kill_strategy=timeout_kill_strategy, returns=returns)
File "/usr/lib/ambari-server/lib/resource_management/core/shell.py", line 150, in _call_wrapper
result = _call(command, **kwargs_copy)
File "/usr/lib/ambari-server/lib/resource_management/core/shell.py", line 314, in _call
raise ExecutionFailed(err_msg, code, out, err)
resource_management.core.exceptions.ExecutionFailed: Execution of 'cp -f /var/lib/ambari-server/resources/stacks/HDF/3.2.b/services/SMARTSENSE/package/files/view/smartsense-ambari-view-2.7.4.jar /var/lib/ambari-server/resources/stacks/HDF/3.2.b/services/SMARTSENSE/package/files/view/smartsense-ambari-view-1.5.0.2.7.4.0-118.jar' returned 1. cp: cannot stat '/var/lib/ambari-server/resources/stacks/HDF/3.2.b/services/SMARTSENSE/package/files/view/smartsense-ambari-view-2.7.4.jar': No such file or directory
ERROR: Exiting with exit code -1.
REASON: Failed to execute after-install hook. Failed with error code after-install
Created 12-09-2019 12:58 PM
You may want to try executing following commands:
1. On the Ambari server host:
ambari-server stop2. On all hosts
ambari-agent stop3. On Ambari server host:
ambari-server uninstall-mpack --mpack-name=hdf-ambari-mpack --verbose
Hope this helps you,
Matt