Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created on 02-18-2016 02:07 PM - edited 09-16-2022 03:04 AM
Similar to this previously posted problem, I am unable to start my ResourceManager. This started after I upgraded my box (Ubuntu 12.04 to 14.04), which most likely also upgrade CDH to 5.5.2.
Error:
2016-02-18 16:40:25,196 FATAL org.apache.hadoop.yarn.server.resourcemanager.ResourceManager: Error starting ResourceManager
org.apache.hadoop.yarn.webapp.WebAppException: Error starting http server
at org.apache.hadoop.yarn.webapp.WebApps$Builder.start(WebApps.java:278)
at org.apache.hadoop.yarn.server.resourcemanager.ResourceManager.startWepApp(ResourceManager.java:985)
at org.apache.hadoop.yarn.server.resourcemanager.ResourceManager.serviceStart(ResourceManager.java:1085)
at org.apache.hadoop.service.AbstractService.start(AbstractService.java:193)
at org.apache.hadoop.yarn.server.resourcemanager.ResourceManager.main(ResourceManager.java:1217)
Caused by: java.io.IOException: Problem in starting http server. Server handlers failed
at org.apache.hadoop.http.HttpServer2.start(HttpServer2.java:900)
at org.apache.hadoop.yarn.webapp.WebApps$Builder.start(WebApps.java:273)
... 4 more
As suggested in the above post, I tried enabling debugging (added "log4j.logger.org.apache.hadoop.yarn.server.resourcemanager=DEBUG,console" to /etc/hadoop/conf/log4j.properties), but I still don't see any reasons this is failing.
Here's my /var/log/hadoop-yarn/yarn-yarn-resourcemanager-elgordo.log file: http://pastebin.com/VPk96KAg
Here's my /var/log/hadoop-yarn/yarn-yarn-resourcemanager-elgordo.out file: http://pastebin.com/2penUUQS
There's a Hadoop JIRA bug fixed in Hadoop 2.7 that sounds like the fix I need (https://issues.apache.org/jira/browse/HADOOP-11754); but I don't see why this is failing for me, but not for everyone else. Is there a configuration change that I can make to avoid this particular Hadoop bug?
There's an option Cloudera JIRA issue that looks similar: https://issues.cloudera.org/browse/DISTRO-754 (no replies on it though).
Created 03-08-2016 12:01 PM
Updated to cdh 5.6.0, everything starting without issue now
Created 03-08-2016 12:01 PM
Updated to cdh 5.6.0, everything starting without issue now