Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Archives of Support Questions (Read Only)

This is an archived board for historical reference. Information and links may no longer be available or relevant
Announcements
This board is archived and read-only for historical reference. To ask a new question, please post a new topic on the appropriate active board.

Server Error when downloading files

avatar
Expert Contributor

We are having an issue previewing and downloading files from File View.

I noticed one other user on here had a similar problem and their solutions did not work for us.

When attempting to preview a file in file view, it is blank and we get an error in the logs:

02 Mar 2017 16:21:57,867 ERROR [ambari-client-thread-8502] [FILES 1.0.0 AUTO_FILES_INSTANCE] FilePreviewService:96 - Error occurred while previewing /topics/xyz/2017/02/15/xyz.1487116808176.log :

And when we attempt to download a file, it states:

{
  "status": 500,
  "message": "Server Error"
}

If anyone has any insight or have had this problem, please assist. Thank you.

1 ACCEPTED SOLUTION

avatar
Master Mentor

@Eric Lloyd

Have you added the "proxyuser" configuration properly in the advanced core-site via Ambari?

hadoop.proxyuser.root.groups=*
hadoop.proxyuser.root.hosts=*

Like:http://docs.hortonworks.com/HDPDocuments/Ambari-2.2.2.18/bk_ambari-views/content/_configuring_your_cluster_for_files_view.html

- Also what is the size of the file that you are trying to download/view? Is it too large?

View solution in original post

3 REPLIES 3

avatar
Expert Contributor

We have also tried creating another Files-View instance and the same error occurs.

avatar
Master Mentor

@Eric Lloyd

Have you added the "proxyuser" configuration properly in the advanced core-site via Ambari?

hadoop.proxyuser.root.groups=*
hadoop.proxyuser.root.hosts=*

Like:http://docs.hortonworks.com/HDPDocuments/Ambari-2.2.2.18/bk_ambari-views/content/_configuring_your_cluster_for_files_view.html

- Also what is the size of the file that you are trying to download/view? Is it too large?

avatar
Expert Contributor

That worked! Thank you!!