Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Archives of Support Questions (Read Only)

This is an archived board for historical reference. Information and links may no longer be available or relevant
Announcements
This board is archived and read-only for historical reference. To ask a new question, please post a new topic on the appropriate active board.

Service stop/start fail after Ambari upgrade due to missing config parameters

avatar
Rising Star

When i upgraded Ambari from 2.2.1 to 2.2.2, then i restart all services in the cluster fails with below error:

raise Fail("Configuration parameter '" + self.name + "' was not found in configurations dictionary!") resource_management.core.exceptions.Fail: Configuration parameter 'managed_hdfs_resource_property_names' was not found in configurations dictionary!

1 ACCEPTED SOLUTION

avatar
Super Collaborator

@Hefei Li

Looks like property managed_hdfs_resource_property_names is missing after upgrade. Please try to set it manually by running the below command :

/var/lib/ambari-server/resources/scripts/configs.sh -port 8080 set localhost <cluster_name> cluster-env "managed_hdfs_resource_property_names" ""

**If its an SSL enabled cluster, then use the below command :

/var/lib/ambari-server/resources/scripts/configs.sh -port 8443 -s set localhost <cluster_name> cluster-env "managed_hdfs_resource_property_names" ""

Once its set, try to restart the services and it should go through fine.

Hope it helps !!

View solution in original post

2 REPLIES 2

avatar
Super Collaborator

@Hefei Li

Looks like property managed_hdfs_resource_property_names is missing after upgrade. Please try to set it manually by running the below command :

/var/lib/ambari-server/resources/scripts/configs.sh -port 8080 set localhost <cluster_name> cluster-env "managed_hdfs_resource_property_names" ""

**If its an SSL enabled cluster, then use the below command :

/var/lib/ambari-server/resources/scripts/configs.sh -port 8443 -s set localhost <cluster_name> cluster-env "managed_hdfs_resource_property_names" ""

Once its set, try to restart the services and it should go through fine.

Hope it helps !!

avatar
Rising Star

Thank you very much for your help, according to the plan you provide, the problem has been solved smoothly