Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 11-12-2016 03:33 AM
solr.jpgOnce I shut down the sandbox and start it again, I am able to start NiFi service smoothly but when I try to start solr service I get an error saying "solr cannot be started again, as it's already running". Also, I can't reach the default homepage.
The only way I can get the solr service up is by "restarting it". But as I restart it and head to default homepage: http://sandbox.hortonworks.com:8983/solr/ it hits me with the error again. Please have a look at the attachment.
Created on 11-12-2016 06:26 AM - edited 08-18-2019 03:27 AM
On Ambari, click on Solr > Configs and under advanced solr-hdfs, set the "Delete write.lock files on HDFS" property to true. Restart Solr.
Created 11-12-2016 03:37 AM
Created 11-12-2016 05:45 AM
see if this solution helps you.
Created on 11-12-2016 06:26 AM - edited 08-18-2019 03:27 AM
On Ambari, click on Solr > Configs and under advanced solr-hdfs, set the "Delete write.lock files on HDFS" property to true. Restart Solr.
Created 11-12-2016 07:36 AM
Thanks a ton for your quick reply! Worked like a charm. 🙂