Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Archives of Support Questions (Read Only)

This is an archived board for historical reference. Information and links may no longer be available or relevant
Announcements
This board is archived and read-only for historical reference. To ask a new question, please post a new topic on the appropriate active board.

SolrCore Initialization Failures

avatar
New Member

solr.jpgOnce I shut down the sandbox and start it again, I am able to start NiFi service smoothly but when I try to start solr service I get an error saying "solr cannot be started again, as it's already running". Also, I can't reach the default homepage.

The only way I can get the solr service up is by "restarting it". But as I restart it and head to default homepage: http://sandbox.hortonworks.com:8983/solr/ it hits me with the error again. Please have a look at the attachment.

1 ACCEPTED SOLUTION

avatar
Super Collaborator

On Ambari, click on Solr > Configs and under advanced solr-hdfs, set the "Delete write.lock files on HDFS" property to true. Restart Solr.

9402-screen-shot-2016-11-12-at-12351-am.png

View solution in original post

4 REPLIES 4

avatar
New Member

avatar
Super Collaborator

see if this solution helps you.

avatar
Super Collaborator

On Ambari, click on Solr > Configs and under advanced solr-hdfs, set the "Delete write.lock files on HDFS" property to true. Restart Solr.

9402-screen-shot-2016-11-12-at-12351-am.png

avatar
New Member

Thanks a ton for your quick reply! Worked like a charm. 🙂