Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created on 12-26-2014 12:49 AM - edited 09-16-2022 02:16 AM
Hi,
Since kerberos is activated, spark history server doesn't start.
| 9:33:47.771 AM | WARN | org.apache.hadoop.ipc.Client | Exception encountered while connecting to the server : javax.security.sasl.SaslException: GSS initiate ailed [Caused by GSSException: No valid credentials provided (Mechanism level: Failed to find any Kerberos tgt)] |
| 9:33:47.771 AM | WARN | org.apache.hadoop.security.UserGroupInformation | PriviledgedActionException as:spark (auth:KERBEROS) cause:java.io.IOException: javax.security.sasl.SaslException: GSS initiate failed [Caused by GSSException: No valid credentials provided (Mechanism level: Failed to find any Kerberos tgt)] |
All other services are OK.
Someone has already had the same error ?
Created 01-08-2015 06:51 AM
Hi,
thank you for your feedback.
I have upgraded into CDH 5.3 and spark history server (via yarn) was successfully started.
regards,
Created 12-29-2014 03:05 PM
Created 01-05-2015 01:32 AM
Hi,
CDH 5.1.2 is used, so we have only one version of spark.
regards,
Created 01-05-2015 11:40 AM
Created 01-05-2015 09:24 PM
Hi Darren,
thank you for your reply.
My CM is 5.1.2 and i'm using Standalone spark.
regards,
Created 01-07-2015 03:29 PM
petibonvm,
I also had this issue in CDH 5.1.x. My advice would be to upgrade to CM/CDH 5.3 and use Spark on YARN. If that is not currently possible, the following work around is posted in the CM 5.1.x Release Notes:
The Spark History Server does not start when Kerberos authentication is enabled.
The Spark History Server does not start when managed by a Cloudera Manager 5.1 instance when Kerberos authentication is enabled.
SPARK_HISTORY_OPTS=-Dspark.history.kerberos.enabled=true \ -Dspark.history.kerberos.principal=principal \ -Dspark.history.kerberos.keytab=keytab
Created 01-08-2015 06:51 AM
Hi,
thank you for your feedback.
I have upgraded into CDH 5.3 and spark history server (via yarn) was successfully started.
regards,