Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created on 09-19-2017 03:28 AM - edited 09-16-2022 05:15 AM
Sqoop list-tables , sqoop eval is successful
But fails in Sqoop import.
sqoop import --connect "jdbc:sqlserver://10.xxx.xxx.xxx:1433; database=Runtime" --username ** --password ****** --table live -m 1
The error is :
Error: java.lang.RuntimeException: java.lang.RuntimeException: com.microsoft.sqlserver.jdbc.SQLServerException: The TCP/IP connection to the host 10.xxx.xxx.xxx, port 1433 has failed. Error: "Connection refused. Verify the connection properties. Make sure that an instance of SQL Server is running on the host and accepting TCP/IP connections at the port. Make sure that TCP connections to the port are not blocked by a firewall.".
Created 10-06-2017 07:58 PM
Sqoop eval and Sqoop list tables requires only the Name node connection with the SQL server.
But for SQOOP import, all the nodes in the cluster needs to have access to the remote SQL server.
Here the Telnet failed from datanodes. It was due the network settings and firewalls configuration.
Later when every node was able to access the Remote SQL server the SQOOP IMPORT was successful.
Created 09-20-2017 04:17 AM
Created on 09-20-2017 10:30 AM - edited 09-20-2017 10:31 AM
I am able to Telnet to the SQL Server. Connected success
Sqoop eval, Sqoop list-database, Sqoop list-tables are all working.
Able to view the status and Log in the Job Browser.
Only sqoop import throws this TCP/IP Connection refused error.
Created 10-06-2017 07:58 PM
Sqoop eval and Sqoop list tables requires only the Name node connection with the SQL server.
But for SQOOP import, all the nodes in the cluster needs to have access to the remote SQL server.
Here the Telnet failed from datanodes. It was due the network settings and firewalls configuration.
Later when every node was able to access the Remote SQL server the SQOOP IMPORT was successful.