Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Archives of Support Questions (Read Only)

This is an archived board for historical reference. Information and links may no longer be available or relevant
Announcements
This board is archived and read-only for historical reference. To ask a new question, please post a new topic on the appropriate active board.

Sqoop import with --direct is not working for Oracle DB

avatar
Rising Star

Hi I am getting error when trying to import the table from Oracle database to Hadoop using Sqoop with --direct utility. The error is, "ERROR manager.SqlManager: Error executing statement: java.sql.SQLSyntaxErrorException: ORA-00942: table or view does not exist java.sql.SQLSyntaxErrorException: ORA-00942: table or view does not exist"

When I take off --direct from sqoop statement, then started importing data.

Is there any other property to be added to the Sqoop statement when using --direct utility?

Thanks!

1 ACCEPTED SOLUTION

avatar
Guru

Hi,

There can be some ORACLE permissions that need to be looked at, as well as ensuring that case-sensitivity are not issues. I recall seeing a similar post in the past that may be a good reference for you: https://community.hortonworks.com/questions/18245/sqoop-connecting-to-oracle-with-direct-option-give...

View solution in original post

2 REPLIES 2

avatar
Guru

Hi,

There can be some ORACLE permissions that need to be looked at, as well as ensuring that case-sensitivity are not issues. I recall seeing a similar post in the past that may be a good reference for you: https://community.hortonworks.com/questions/18245/sqoop-connecting-to-oracle-with-direct-option-give...

avatar
Rising Star

Yes, that worked. after giving SELECT_CATALOG_ROLE privileges, direct option is working.