Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 01-06-2016 10:16 AM
Hi, I'm trying to submit a topology on storm cluster using StormSubmitter , however I got the following error: [ERROR] Failed to execute goal org.codehaus.mojo:exec-maven-plugin:1.2.1:java (default-cli) on project realtime_piplines: An exception occured while executing the Java class. null: InvocationTargetException: org.apache.thrift7.protocol.TProtocolException: Required field 'nimbus_uptime_secs' is unset! I am running HDP 2.3.4 with Storm version '0.10.0' on RHEL 6.5.
Thanks in advance,
Created 01-08-2016 03:34 AM
@Yuri Chemolosov @Artem Ervits one of the workarounds I think of is to make storm-0.11-SNAPSHOT as dependency at the client side for the topology and use the StormSubmitter for 0.11-SNAPSHOT version.
add the following repository in your pom.xml https://repository.apache.org/content/repositories/snapshots/ to get the latest snapshot for storm.
Created 01-10-2016 10:07 AM
Thanks all,
Changing storm version (by downgrading), setting the nimbus_uptime_secs did not work for me. However, I have managed to deploy the topology remotly, 2 things I did:
1. Used storm client instead of run the topology using mvn exec:java
2. Removed configuration from source code and configure ~/.storm/storm.yaml instead.
Now I have hive, hdfs bolts and kafka spout only working in the local mode, I will investigate, help is appreciated.
Thanks again
Created 01-12-2016 03:15 PM
Solution is to tell your build/submit tool to use the storm library from HDP repository. Here how it is described for streamparse
Created 01-14-2016 11:53 AM
Thank you, it worked fine.