Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created on 09-26-2016 07:18 AM - edited 09-16-2022 03:41 AM
Hi All,
For some reason I can't install the hadoop components manually, getting the error:
https://archive.cloudera.com/cdh5/redhat/6/x86_64/cdh/5/RPMS/x86_64/zookeeper-3.4.5%2Bcdh5.8.0%2B94-1.cdh5.8.0.p0.76.el6.x86_64.rpm: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 404 Not Found" Trying other mirror.
I followed this link CentOS installation.
This is my repo:
[root@4f229e9c9172 ~]# cat /etc/yum.repos.d/cloudera-cdh5.repo [cloudera-cdh5] name=Cloudera's Distribution for Hadoop, Version 5 baseurl=https://archive.cloudera.com/cdh5/redhat/6/x86_64/cdh/5/ gpgkey = https://archive.cloudera.com/cdh5/redhat/6/x86_64/cdh/RPM-GPG-KEY-cloudera gpgcheck = 1
Please assist, This issue is from the last few hours..
Created 10-06-2016 04:40 AM
In order to solve the issue I created the file(/etc/yum.repos.d/cloudera-cdh5.repo) by myself and edited it as below:
[cloudera-cdh5] name=Cloudera's Distribution for Hadoop, Version 5 baseurl=https://archive.cloudera.com/cdh5/redhat/6/x86_64/cdh/5.8.0/ gpgkey = https://archive.cloudera.com/cdh5/redhat/6/x86_64/cdh/RPM-GPG-KEY-cloudera gpgcheck = 1
The problem was with the baseurl I've added the 5.8.0 which fixed the issue ->
https://archive.cloudera.com/cdh5/redhat/6/x86_64/cdh/5.8.0/
Created 09-26-2016 07:22 AM
This is what i'm tring to install:
[root@4f229e9c9172 ~]# yum install -y hadoop-0.20-mapreduce-jobtracker hadoop-hdfs-namenode hadoop-client hadoop-hdfs-datanode hadoop-0.20-mapreduce-tasktracker
The full error:
https://archive.cloudera.com/cdh5/redhat/6/x86_64/cdh/5/RPMS/x86_64/zookeeper-3.4.5%2Bcdh5.8.0%2B94-1.cdh5.8.0.p0.76.el6.x86_64.rpm: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 404 Not Found" Trying other mirror. Error Downloading Packages: hadoop-0.20-mapreduce-jobtracker-2.6.0+cdh5.8.0+1601-1.cdh5.8.0.p0.93.el6.x86_64: failure: RPMS/x86_64/hadoop-0.20-mapreduce-jobtracker-2.6.0+cdh5.8.0+1601-1.cdh5.8.0.p0.93.el6.x86_64.rpm from cloudera-cdh5: [Errno 256] No more mirrors to try. hadoop-mapreduce-2.6.0+cdh5.8.0+1601-1.cdh5.8.0.p0.93.el6.x86_64: failure: RPMS/x86_64/hadoop-mapreduce-2.6.0+cdh5.8.0+1601-1.cdh5.8.0.p0.93.el6.x86_64.rpm from cloudera-cdh5: [Errno 256] No more mirrors to try. parquet-1.5.0+cdh5.8.0+174-1.cdh5.8.0.p0.71.el6.noarch: failure: RPMS/noarch/parquet-1.5.0+cdh5.8.0+174-1.cdh5.8.0.p0.71.el6.noarch.rpm from cloudera-cdh5: [Errno 256] No more mirrors to try. zookeeper-3.4.5+cdh5.8.0+94-1.cdh5.8.0.p0.76.el6.x86_64: failure: RPMS/x86_64/zookeeper-3.4.5+cdh5.8.0+94-1.cdh5.8.0.p0.76.el6.x86_64.rpm from cloudera-cdh5: [Errno 256] No more mirrors to try.
Created 10-06-2016 04:40 AM
In order to solve the issue I created the file(/etc/yum.repos.d/cloudera-cdh5.repo) by myself and edited it as below:
[cloudera-cdh5] name=Cloudera's Distribution for Hadoop, Version 5 baseurl=https://archive.cloudera.com/cdh5/redhat/6/x86_64/cdh/5.8.0/ gpgkey = https://archive.cloudera.com/cdh5/redhat/6/x86_64/cdh/RPM-GPG-KEY-cloudera gpgcheck = 1
The problem was with the baseurl I've added the 5.8.0 which fixed the issue ->
https://archive.cloudera.com/cdh5/redhat/6/x86_64/cdh/5.8.0/