Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 08-24-2016 03:30 PM
Nonestdout:
DB connection check started.
WARNING: File /var/lib/ambari-agent/cache/DBConnectionVerification.jar already exists, assuming it was downloaded before
WARNING: File /var/lib/ambari-agent/cache/mysql-jdbc-driver.jar already exists, assuming it was downloaded before
2016-08-24 15:29:30,162 - call['/usr/lib/jvm/jre-1.7.0-openjdk.x86_64/bin/java -cp /var/lib/ambari-agent/cache/DBConnectionVerification.jar:/var/lib/ambari-agent/cache/mysql-jdbc-driver.jar -Djava.library.path=/var/lib/ambari-agent/cache org.apache.ambari.server.DBConnectionVerification "jdbc:mysql://manager/ranger" rangerdba [PROTECTED] com.mysql.jdbc.Driver'] {}
2016-08-24 15:29:30,688 - call returned (1, "ERROR: Unable to connect to the DB. Please check DB connection properties.\njava.sql.SQLException: Access denied for user 'rangerdba'@'manager' (using password: YES)")structured_out: ERROR: Unable to connect to the DB. Please check DB connection properties. java.sql.SQLException: Access denied for user 'rangerdba'@'manager' (using password: YES)
Created 08-24-2016 04:10 PM
i found the solution , should execute /usr/bin/mysql_secure_installation then set a password for root
Created 08-24-2016 03:39 PM
You need to create the user rangerdba with password manager to get the same working.
For more information on how to create the user please follow the article:
Created 08-24-2016 03:39 PM
i have create the user randerdba im following the same documentation
Created 08-24-2016 04:10 PM
i found the solution , should execute /usr/bin/mysql_secure_installation then set a password for root
Created 08-25-2016 09:02 AM
use the following commands to create the 'rangerdba'@'manager' user
CREATE USER 'rangerdba'@'manager' IDENTIFIED BY 'rangerdba'; GRANT ALL PRIVILEGES ON *.* TO 'rangerdba'@'manager';
Created 08-25-2016 09:47 AM
i have create this user , i found the solution should execute /usr/bin/mysql_secure_installation then set a password for the root