Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created on 06-15-2017 02:14 PM - edited 09-16-2022 04:46 AM
Unable to connect from spotfire to hive using Knox. getting following exceptions.
WARN [HiveServer2-HttpHandler-Pool: Thread-260]: thrift.ThriftCLIService (ThriftCLIService.java:OpenSession(324)) - Error ope
ning session:
org.apache.hive.service.cli.HiveSQLException: Failed to validate proxy privilege of knox for user1
at org.apache.hive.service.auth.HiveAuthFactory.verifyProxyAccess(HiveAuthFactory.java:443) ~[hive-service-2.1.0.2.6.0.3-8.jar:2.1.0.2.6.0.3-8
]
at org.apache.hive.service.cli.thrift.ThriftCLIService.getProxyUser(ThriftCLIService.java:809) ~[hive-service-2.1.0.2.6.0.3-8.jar:2.1.0.2.6.0.
3-8]
at org.apache.hive.service.cli.thrift.ThriftCLIService.getUserName(ThriftCLIService.java:382) ~[hive-service-2.1.0.2.6.0.3-8.jar:2.1.0.2.6.0.3
-8]
Created 06-16-2017 11:29 AM
Can you also check the following properties and modify it according to your needs ?
webhcat.proxyuser.knox.hosts * webhcat.proxyuser.knox.groups *
As Jay pointed - once you set the appropriate permission restart all the necessary components + all hive services.
Created 06-15-2017 02:24 PM
Have you changed the "hadoop.proxyuser.knox.groups" or "hadoop.proxyuser.knox.hosts" to access hive2 through knox ? Either set the values for these properties to * or the user which is failing.
If yes, then you will have to restart the Hive.
Restart the Hive service, so that it operates using these updated core-site configurations.
You are uisng HDP 2.6 but for Old HDP Spack (2.5) there was a similar issue reported as known issue. Please see: BUG-66998 in https://docs.hortonworks.com/HDPDocuments/Ambari-2.5.0.3/bk_ambari-release-notes/content/ambari_reln...
Created 06-15-2017 06:11 PM
thanks for the reply. Both this property are set to * in my current cluster
Created 06-15-2017 06:13 PM
Created 06-15-2017 06:59 PM
Created 06-16-2017 11:29 AM
Can you also check the following properties and modify it according to your needs ?
webhcat.proxyuser.knox.hosts * webhcat.proxyuser.knox.groups *
As Jay pointed - once you set the appropriate permission restart all the necessary components + all hive services.