Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created on 10-09-2014 07:31 AM - edited 09-16-2022 02:09 AM
I am trying to connect to beeline.
Getting the below error messege:-
# /usr/lib/hive/bin/beeline
-hiveconf (No such file or directory)
hive.aux.jars.path=file:/usr/lib/hive/lib/hive-hbase-handler-0.12.0-cdh5.1.2.jar,file:/usr/lib/hbase/hbase-server.jar,file:/usr/lib/hbase/hbase-hadoop-compat.jar,file:/usr/lib/hbase/hbase-protocol.jar,file:/usr/lib/hbase/hbase-hadoop2-compat.jar,file:/usr/lib/hbase/lib/htrace-core.jar,file:/usr/lib/hbase/lib/htrace-core-2.04.jar,file:/usr/lib/hbase/hbase-client.jar,file:/usr/lib/hbase/hbase-common.jar,file:/usr/share/java/mysql-connector-java.jar,file:/usr/share/cmf/lib/postgresql-9.0-801.jdbc4.jar,file:/usr/share/java/oracle-connector-java.jar (No such file or directory)
Beeline version 0.12.0-cdh5.1.2 by Apache Hive
beeline>
beeline> !connect jdbc:hive2://localhost:10000 hive hive123 org.apache.hive.jdbc.HiveDriver
Connecting to jdbc:hive2://localhost:10000
Error: Could not open connection to jdbc:hive2://localhost:10000: java.net.ConnectException: Connection refused (state=08S01,code=0)
0: jdbc:hive2://localhost:10000>
I am not able trace what I am missing here.
Any help is appreciated.
Thanks,
Rudra
Created 10-10-2014 03:52 AM
The issue got resolved after I configured the Hive gateway server in the edge node.
Created 10-09-2014 11:21 AM
Hi,
I had the same issue on HUE connecting to jdbc:hive2://localhost:10000
Have you installed hive-server2 ?
ps -aux | grep hive-server2
If not, try this http://www.cloudera.com/content/cloudera/en/documentation/cdh4/v4-2-0/CDH4-Installation-Guide/cdh4ig...
Regards,
Fabricio
Created 10-10-2014 03:52 AM
The issue got resolved after I configured the Hive gateway server in the edge node.