Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 06-23-2016 11:56 PM
i am getting following logs in my ambari-server logs . I check the database and there is no entry of this cluster name "oldclustername" in any tables(i grepped on my dump file and also checked manually in all tables). I named my cluster as "oldclustername" but then renamed it to "newclustername" but logs are still showing these messages. Only table I see suspicious entries is ambari.request which has cluster id=-1 and 2, where cluster_id correctly maps to my newclustername but -1 looks like a wrong entry. Any suggestions where should I look?
23 Jun 2016 23:38:32,233 ERROR [alert-event-bus-2] AlertReceivedListener:329 - Unable to process alert yarn_nodemanager_health for an invalid cluster named oldclustername 23 Jun 2016 23:38:32,361 ERROR [alert-event-bus-2] AlertReceivedListener:329 - Unable to process alert ams_metrics_monitor_process for an invalid cluster named oldclustername 23 Jun 2016 23:38:32,362 WARN [alert-event-bus-2] AlertReceivedListener:248 - Cluster lookup failed for clusterName=oldclustername 23 Jun 2016 23:38:32,362 WARN [alert-event-bus-2] AlertReceivedListener:134 - Received an alert for ambari_agent_disk_usage which is a definition that does not exist anymore 23 Jun 2016 23:38:32,362 ERROR [alert-event-bus-2] AlertReceivedListener:329 - Unable to process alert kafka_broker_process for an invalid cluster named oldclustername 23 Jun 2016 23:38:32,942 ERROR [alert-event-bus-2] AlertReceivedListener:329 - Unable to process alert datanode_webui for an invalid cluster named oldclustername 23 Jun 2016 23:38:32,943 ERROR [alert-event-bus-2] AlertReceivedListener:329 - Unable to process alert datanode_process for an invalid cluster named oldclustername 23 Jun 2016 23:38:32,943 WARN [alert-event-bus-2] AlertReceivedListener:248 - Cluster lookup failed for clusterName=oldclustername 23 Jun 2016 23:38:32,943 WARN [alert-event-bus-2] AlertReceivedListener:134 - Received an alert for ambari_agent_disk_usage which is a definition that does not exist anymore 23 Jun 2016 23:38:32,943 ERROR [alert-event-bus-2] AlertReceivedListener:329 - Unable to process alert yarn_nodemanager_webui for an invalid cluster named oldclustername 23 Jun 2016 23:38:32,943 ERROR [alert-event-bus-2] AlertReceivedListener:329 - Unable to process alert ams_metrics_monitor_process for an invalid cluster named oldclustername 23 Jun 2016 23:38:32,943 ERROR [alert-event-bus-2] AlertReceivedListener:329 - Unable to process alert yarn_nodemanager_health for an invalid cluster named oldclustername
Created 06-24-2016 02:29 AM
There is a bug on older Ambari versions where if you rename a cluster (or delete a cluster), you'll get these errors in your logs. It's because the agents have not un-scheduled the old cluster's alerts. You can just restart the agents to have these errors go away.
Created 06-24-2016 02:29 AM
There is a bug on older Ambari versions where if you rename a cluster (or delete a cluster), you'll get these errors in your logs. It's because the agents have not un-scheduled the old cluster's alerts. You can just restart the agents to have these errors go away.
Created 06-24-2016 09:26 PM
I restarted the agents but looks like the errors are still present. I see the old cluster name in a execution_commands table. I have identified the task_id which are having the command haivng my old clustername. Should I delete them from the database?
Created 07-21-2016 07:46 PM
Did you solved the issue? We have the same erros in our 2.4.2 cluster.
ERROR [alert-event-bus-2] AlertReceivedListener:341 - Unable to process alert ams_metrics_monitor_process for an invalid cluster named XXXX.
WARN [qtp-ambari-client-68] ViewRegistry:855 - Could not find the cluster identified by XXXX.