Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Archives of Support Questions (Read Only)

This is an archived board for historical reference. Information and links may no longer be available or relevant
Announcements
This board is archived and read-only for historical reference. To ask a new question, please post a new topic on the appropriate active board.

Unable to see Hive tables in Atlas UI after kerberized cluster + Ranger enabled, not able to view any object in Atlas UI.??

avatar
Contributor

I see below error in kafka logs,

org.apache.kafka.common.errors.TopicAuthorizationException: Not authorized to access topics: [ATLAS_ENTITIES]\n"})
1 ACCEPTED SOLUTION

avatar
Expert Contributor

@rakanchi

Look like permission are not set correctly for topics, verify the Kafka policies in Ranger are correct for ATLAS_HOOK topic, ATLAS_ENTITIES topic

check follow link, https://github.com/emaxwell-hw/Atlas-Ranger-Tag-Security.

Also provide permissions to 'hive' and 'atlas' users on atlas kafka topics ATLAS_HOOK and ATLAS_ENTITIES.

Let me know if it helps!

View solution in original post

1 REPLY 1

avatar
Expert Contributor

@rakanchi

Look like permission are not set correctly for topics, verify the Kafka policies in Ranger are correct for ATLAS_HOOK topic, ATLAS_ENTITIES topic

check follow link, https://github.com/emaxwell-hw/Atlas-Ranger-Tag-Security.

Also provide permissions to 'hive' and 'atlas' users on atlas kafka topics ATLAS_HOOK and ATLAS_ENTITIES.

Let me know if it helps!