Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 08-13-2017 04:17 PM
raise Fail("Applying %s failed, parent directory %s doesn't exist" % (self.resource, dirname))
resource_management.core.exceptions.Fail: Applying File['/var/lib/ambari-agent/tmp/changeUid.sh'] failed, parent directory /var/lib/ambari-agent/tmp doesn't exist
Error: Error: Unable to run the custom hook script ['/usr/bin/python', '/var/lib/ambari-agent/cache/stacks/HDP/2.0.6/hooks/before-ANY/scripts/hook.py', 'ANY', '/var/lib/ambari-agent/data/command-11717.json', '/var/lib/ambari-agent/cache/stacks/HDP/2.0.6/hooks/before-ANY', '/var/lib/ambari-agent/data/structured-out-11717.json', 'INFO', '/var/lib/ambari-agent/tmp', 'PROTOCOL_TLSv1']
Ambari version is 2.5
This issue is appearing on master node. All the services on master node is down.
Initially one of the data node was not able to make connection with master node. It seems that firewalld was not disable. we install the service and disabled it. and restarted ambari. After restarting ambari all the services on master node went down with above error. As this is master node so we wouldn't able to re-set ambari or reinstall it.
Created 08-14-2017 12:32 AM
Is that ambari-agent service still running? Or try to restart it.
[root@hdptest ~]# /etc/init.d/ambari-agent status Found ambari-agent PID: 63290 ambari-agent running. Agent PID at: /run/ambari-agent/ambari-agent.pid Agent out at: /var/log/ambari-agent/ambari-agent.out Agent log at: /var/log/ambari-agent/ambari-agent.log
Created 08-14-2017 12:32 AM
Is that ambari-agent service still running? Or try to restart it.
[root@hdptest ~]# /etc/init.d/ambari-agent status Found ambari-agent PID: 63290 ambari-agent running. Agent PID at: /run/ambari-agent/ambari-agent.pid Agent out at: /var/log/ambari-agent/ambari-agent.out Agent log at: /var/log/ambari-agent/ambari-agent.log
Created 08-15-2017 10:02 AM
Thanks Mark. Stopping and Starting agent (on masternode) resolved the problem
Created 08-14-2017 09:15 AM
Can you attach the ambari-server log.
Created 08-15-2017 10:04 AM
Thanks for responding Geoffery. Above solution provided by Mark resolved the issue./