Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created on 05-12-2015 09:12 PM - edited 09-16-2022 02:28 AM
Hi team,
I am getting below error while trying to use sqoop syntax. Unable to use sqoop on cloudera CDH5
root@blrrndtipamo02:/opt/cloudera/parcels/CDH/lib/sqoop/bin# sqoop version
Error: /usr/lib/sqoop/../hadoop does not exist!
Please set $HADOOP_COMMON_HOME to the root of your Hadoop installation.
root@blrrndtipamo02:/opt/cloudera/parcels/CDH/lib/sqoop/bin# sqoop help
Error: /usr/lib/sqoop/../hadoop does not exist!
Please set $HADOOP_COMMON_HOME to the root of your Hadoop installation.
Please suggest
Created 08-21-2015 03:04 AM
Issue fixed with below steps I performed.
Command for soft link:
ln -s /opt/cloudera/parcels/CDH-5.4.0-1.cdh5.4.0.p0.27/lib/sqoop2/webapps/sqoop/WEB-INF/lib/derby.jar /opt/cloudera/parcels/CDH-5.4.0-1.cdh5.4.0.p0.27/jars/derby.jar
Created 05-20-2015 09:37 PM
Yes, permission all fine.
Checked jar file is placed in /var/lib/sqoop path.
I am using Debain Wheezy build with CDH5.3.3 parcels version. I do not see only sqoop as it shows sqoop 2 alone as in screen shoft below. However, it is doesn't work.
Created 08-21-2015 03:04 AM
Issue fixed with below steps I performed.
Command for soft link:
ln -s /opt/cloudera/parcels/CDH-5.4.0-1.cdh5.4.0.p0.27/lib/sqoop2/webapps/sqoop/WEB-INF/lib/derby.jar /opt/cloudera/parcels/CDH-5.4.0-1.cdh5.4.0.p0.27/jars/derby.jar