Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created on 02-15-2016 07:14 PM - edited 09-16-2022 03:04 AM
I am trying to create a table from the tutorials. I was able to upload the Batting.csv file, but when I take the next step of creating the table to hold this file it gives me the error:
User: ambari is not allowed to impersonate USERNAME
Can anyone explain what I am doing wrong?
Thank you
Created 02-17-2016 01:29 AM
@Jeremy Salazar since the error states that the user is "ambari" you will need to add the following values to the HDFS custom core-site configuration:
hadoop.proxyuser.ambari.groups=* hadoop.proxyuser.ambari.hosts=*
Once that's done you'll need to follow @Neeraj Sabharwal step and create your home directory and assign access.
Created 02-15-2016 07:17 PM
Please see this guide. You have to set proxy user setting
also, after logging into vm as root
su - hdfs
hdfs dfs -mkdir /user/admin
hdfs dfs -chown -R admin:hdfs /user/admin
Created 02-15-2016 07:32 PM
Ok I was able to achieve the first part in adding the property. I want to verify what I need to do for the next piece?
also, after logging into vm as root
su - hdfs
hdfs dfs -mkdir /user/admin
hdfs dfs -chown -R admin:hdfs /user/admin
Thank you for the help!
Created 02-15-2016 07:37 PM
@Jeremy Salazar You are on right track. Yes to those steps
Official doc
Created 02-15-2016 08:05 PM
I had to restart the hadoop01 host. Once that finished and everything was green I then tried to find the switch to hdfs system account user. I don't see where that is located within that Host?
Created 02-15-2016 09:55 PM
@Jeremy Salazar hdfs is service account...Login to namenode and you will find it there.
Created 02-17-2016 01:29 AM
@Jeremy Salazar since the error states that the user is "ambari" you will need to add the following values to the HDFS custom core-site configuration:
hadoop.proxyuser.ambari.groups=* hadoop.proxyuser.ambari.hosts=*
Once that's done you'll need to follow @Neeraj Sabharwal step and create your home directory and assign access.