Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Archives of Support Questions (Read Only)

This is an archived board for historical reference. Information and links may no longer be available or relevant
Announcements
This board is archived and read-only for historical reference. To ask a new question, please post a new topic on the appropriate active board.

While starting ambari server, I am getting IndexError: list index out of range exception.

avatar

Here is the detail Exception : Using python /usr/bin/python2.7

Starting ambari-server

Traceback (most recent call last):

File "/usr/sbin/ambari-server.py", line 279, in <module>

PG_HBA_DIR = utils.get_postgre_hba_dir(OS_FAMILY)

File "/usr/lib/python2.6/site-packages/ambari_server/utils.py", line 198, in get_postgre_hba_dir

os.symlink(glob.glob(PG_HBA_INIT_FILES[OS_FAMILY] + '*')[0],

IndexError: list index out of range.

Is this specific to CentOS 7 ? Anyone ran into similar issue?

1 ACCEPTED SOLUTION

avatar
Guru

which version of ambari is this? On current latest ambari version (2.2.2.0) I see an explicit check to not go to that code.

 elif OSCheck.is_redhat7()

return PG_HBA_ROOT_DEFAULT

View solution in original post

2 REPLIES 2

avatar
Guru

which version of ambari is this? On current latest ambari version (2.2.2.0) I see an explicit check to not go to that code.

 elif OSCheck.is_redhat7()

return PG_HBA_ROOT_DEFAULT

avatar

Thank you for pointing that out by mistake I have updated the Ambari with older version. It fixed now.