Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 01-03-2017 12:21 PM
I've modified the principal maxlife to 5min, as per the theory I should not be able to access the hdfs after 5min. But for me ticket is expiring after 10min. Any idea?
WARN ipc.Client: Exception encountered while connecting to the server : javax.security.sasl.SaslException: GSS initiate failed [Caused by GSSException: No valid credentials provided (Mechanism level: Failed to find any Kerberos tgt)]
modified maxlife using below command,
modprinc -maxlife "5minutes" [email protected]
Created 01-03-2017 12:35 PM
The default value for maximum clock skew is 300 seconds, or five minutes. So by default, the kerberos server will refuse to issue tickets only if the clocks are out of sync by more than 5 minutes, hence you are allowed to access the service or renew tickets till the acceptable clock skew time. MIT ClockSkew
Created 01-03-2017 12:35 PM
The default value for maximum clock skew is 300 seconds, or five minutes. So by default, the kerberos server will refuse to issue tickets only if the clocks are out of sync by more than 5 minutes, hence you are allowed to access the service or renew tickets till the acceptable clock skew time. MIT ClockSkew
Created 01-03-2017 12:56 PM
thanks @krajguru for response. So it is expected behavior. Can we reduce this clock skew and is it advised to reduce it?
Created 01-03-2017 01:47 PM