Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 06-22-2017 08:30 AM
Trying to start Zeppelin server from Ambari. This worked fine until once, when Ambari fails to start it with:
Traceback (most recent call last):
File "/var/lib/ambari-agent/cache/common-services/ZEPPELIN/0.6.0.2.5/package/scripts/master.py", line 450, in <module>
Master().execute()
File "/usr/lib/python2.6/site-packages/resource_management/libraries/script/script.py", line 329, in execute
method(env)
File "/var/lib/ambari-agent/cache/common-services/ZEPPELIN/0.6.0.2.5/package/scripts/master.py", line 227, in start
self.update_kerberos_properties()
File "/var/lib/ambari-agent/cache/common-services/ZEPPELIN/0.6.0.2.5/package/scripts/master.py", line 302, in update_kerberos_properties
and params.zookeeper_znode_parent not in interpreter['properties']['phoenix.url']:
KeyError: 'phoenix.url'
Ambari 2.5.0, HDP 2.6.0.3
Created 06-22-2017 10:14 AM
Can you please confirm it is Ambari 2.5.0?
I see that Line 302 where this is failing code matches Ambari 2.5.1 (not Ambari 2.5.0)
1. (Ambari 2.5.1) https://github.com/apache/ambari/blob/release-2.5.1/ambari-server/src/main/resources/common-services...
2. (Ambari 2.5.0) https://github.com/apache/ambari/blob/release-2.5.0/ambari-server/src/main/resources/common-services...
.
By any chance have you recently upgraded your ambari ? Also the Agent? Are the RPMs are of same version.
rpm -qa | grep ambari
.
Created 06-22-2017 10:14 AM
Can you please confirm it is Ambari 2.5.0?
I see that Line 302 where this is failing code matches Ambari 2.5.1 (not Ambari 2.5.0)
1. (Ambari 2.5.1) https://github.com/apache/ambari/blob/release-2.5.1/ambari-server/src/main/resources/common-services...
2. (Ambari 2.5.0) https://github.com/apache/ambari/blob/release-2.5.0/ambari-server/src/main/resources/common-services...
.
By any chance have you recently upgraded your ambari ? Also the Agent? Are the RPMs are of same version.
rpm -qa | grep ambari
.
Created 06-22-2017 10:30 AM
thanks.
Yeah... forget that I upgraded yesterday. I have ambari-agent and ambari-server 2.5.1. ambari-infra-solr, ambari-metrics-collector,.... are still 2.5.0.3
As a workaround I uncommented the piece of code in the master.py file.
Is there another possible solution?
Created 06-22-2017 10:39 AM
Post install upgrades are necessary to be performed like AMS upgrade.
The piece of code that you removed is actually added there intentially to fix the issue reported in:
AMBARI-20888. wrong ZK parent node (hbase-unsecure) getting configured as part of the jdbc(phoenix) URL on ubuntu secured cluster.
.
Specially for kerberized environment.
Created 06-22-2017 11:28 AM
Thanks @Jay SenSharma
Created 07-18-2017 12:46 PM
Hi All,
I'm getting the same issue after kerberizing the cluster though it's a newly built one.
HDP-2.6.1.0
Ambari - 2.5.1.0
Created 08-16-2017 08:18 PM
This is a bug in Ambari 2.5.1 [https://issues.apache.org/jira/browse/AMBARI-21473]
Resolution:
Remove /etc/zeppelin/conf/interpreter.json file and restart Zeppelin service