Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Archives of Support Questions (Read Only)

This is an archived board for historical reference. Information and links may no longer be available or relevant
Announcements
This board is archived and read-only for historical reference. To ask a new question, please post a new topic on the appropriate active board.

Zeppelin phoenix error

avatar

I am getting the following error in zeppelin when i try to query phoenix,

ERROR 726 (43M10): Inconsistent namespace mapping properites.. Cannot initiate connection as SYSTEM:CATALOG is found but client does not have phoenix.schema.isNamespaceMappingEnabled enabled class java.sql.SQLException org.apache.phoenix.exception.SQLExceptionCode$Factory$1.newException(SQLExceptionCode.java:455)

I have set the "phoenix.schema.isNamespaceMappingEnabled" to true in zeppelin interpreter setting. i have attached the screen shot too. any thoughts on how to fix it.zeppelin-phoenix.png

1 ACCEPTED SOLUTION

avatar

Luckily i found out the cause.

The property i was trying to set is phoenix.schema.isNamespaceMappingEnabled. The property had phoenix. which is a prefix for the phoenix interpreter. so it was not set properly on the interpreter side. so the right property i need to set is phoenix.phoenix.schema.isNamespaceMappingEnabled so the prefix gets correctly parsed. I found out this from the logs

JDBCInterpreter.java[open]:142) - key: phoenix, value: schema.isNamespaceMappingEnabled (before the change)

JDBCInterpreter.java[open]:142) - key: phoenix, value: phoenix.schema.isNamespaceMappingEnabled (after the change)

Hope this helps

View solution in original post

1 REPLY 1

avatar

Luckily i found out the cause.

The property i was trying to set is phoenix.schema.isNamespaceMappingEnabled. The property had phoenix. which is a prefix for the phoenix interpreter. so it was not set properly on the interpreter side. so the right property i need to set is phoenix.phoenix.schema.isNamespaceMappingEnabled so the prefix gets correctly parsed. I found out this from the logs

JDBCInterpreter.java[open]:142) - key: phoenix, value: schema.isNamespaceMappingEnabled (before the change)

JDBCInterpreter.java[open]:142) - key: phoenix, value: phoenix.schema.isNamespaceMappingEnabled (after the change)

Hope this helps