Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Archives of Support Questions (Read Only)

This is an archived board for historical reference. Information and links may no longer be available or relevant
Announcements
This board is archived and read-only for historical reference. To ask a new question, please post a new topic on the appropriate active board.

ZooKeeper Server failed when we start the ZKFailoverControl service

avatar

when we start the ZKFailoverControl service , ZooKeeper Server will failed after few seconds

for example

from the ambari - ZooKeeper Server service is stable , but when we start the ZKFailoverControl service ,

then immeditly ZooKeeper Server will fail and also the ZKFailoverControl service itself

please advice hat could be the root cause for that?

57423-capture.png

Michael-Bronson
1 ACCEPTED SOLUTION

avatar
Master Mentor

@Michael Bronson

Can you please share the following log file content so that we can see the cause of failure? The latest log of the ZKFC process

# ls -lart /var/log/hadoop/hdfs/hadoop-hdfs-zkfc*.log
# ls -lart /var/log/hadoop/hdfs/hadoop-hdfs-zkfc*.out

.

View solution in original post

1 REPLY 1

avatar
Master Mentor

@Michael Bronson

Can you please share the following log file content so that we can see the cause of failure? The latest log of the ZKFC process

# ls -lart /var/log/hadoop/hdfs/hadoop-hdfs-zkfc*.log
# ls -lart /var/log/hadoop/hdfs/hadoop-hdfs-zkfc*.out

.