Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Archives of Support Questions (Read Only)

This is an archived board for historical reference. Information and links may no longer be available or relevant
Announcements
This board is archived and read-only for historical reference. To ask a new question, please post a new topic on the appropriate active board.

Zookeeper, NameNode etc - Permission denied because of "number-users"

avatar

Hi,

for everyone experiencing the error in the screenshot... check if there is some hidden central user management system active - which deletes your users...

Daniel

40467-unbenannt.png

1 ACCEPTED SOLUTION

avatar

central user management overrides local user installations...

View solution in original post

4 REPLIES 4

avatar
Rising Star

Did you install HDP Client on that server?

avatar

are you referring to the "hdfs client"? if so, yes.

The Master also contains both, ambari-server as well as the ambari-agent.

avatar
New Member

Your files are owned by UID's instead of usernames.. May be your unix team has changed the UID's of service users..
Change the ownership of files owned by 37990 to 'hdfs' user by using chown linux command..

avatar

central user management overrides local user installations...