Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created on
06-16-2016
09:46 AM
- last edited on
04-21-2026
06:51 AM
by
GrazittiAPI
I've configured hue on hdp2.4.2. and refer below docs.
and encountered below issues. anyone can help this
Traceback (most recent call last): File "/usr/lib/hue/desktop/core/src/desktop/views.py", line 355, in _get_config_errors error_list.extend(validator(user)) File "/usr/lib/hue/desktop/libs/liboozie/src/liboozie/conf.py", line 80, in config_validator message=_('Oozie Share Lib not installed in default location.'))) File "/usr/lib/hue/desktop/core/src/desktop/lib/conf.py", line 658, in validate_path if path is None or not fs.exists(path): File "/usr/lib/hue/desktop/libs/hadoop/src/hadoop/fs/webhdfs.py", line 217, in exists return self._stats(path) is not None File "/usr/lib/hue/desktop/libs/hadoop/src/hadoop/fs/webhdfs.py", line 205, in _stats raise ex WebHdfsException: RemoteException: User: httpfs is not allowed to impersonate hdfs (error 500) [16/Jun/2016 09:10:34 +0000] supervisor ERROR Exception in supervisor main loop Traceback (most recent call last): File "/usr/lib/hue/desktop/core/src/desktop/supervisor.py", line 414, in main wait_loop(sups, options) File "/usr/lib/hue/desktop/core/src/desktop/supervisor.py", line 424, in wait_loop time.sleep(1) File "/usr/lib/hue/desktop/core/src/desktop/supervisor.py", line 221, in sig_handler raise SystemExit("Signal %d received. Exiting" % signum) SystemExit: Signal 15 received. Exiting [16/Jun/2016 02:10:47 +0000] webhdfs ERROR Failed to determine superuser of WebHdfs at http://etl01.prod2.everstring.com:14000/webhdfs/v1/: RemoteException: User: httpfs is not allowed to impersonate hue (error 500)
Created 06-16-2016 09:53 AM
Can you please check if you have below properties?.
<property> <name>hadoop.proxyuser.httpfs.groups</name> <value>*</value> </property> <property> <name>hadoop.proxyuser.httpfs.hosts</name> <value>*</value> </property>
See this doc http://docs.hortonworks.com/HDPDocuments/HDP2/HDP-2.3.0/bk_hadoop-ha/content/ha-nn-deploy-hue.html
Created 06-16-2016 09:53 AM
Can you please check if you have below properties?.
<property> <name>hadoop.proxyuser.httpfs.groups</name> <value>*</value> </property> <property> <name>hadoop.proxyuser.httpfs.hosts</name> <value>*</value> </property>
See this doc http://docs.hortonworks.com/HDPDocuments/HDP2/HDP-2.3.0/bk_hadoop-ha/content/ha-nn-deploy-hue.html
Created 06-16-2016 09:58 AM
it's in place. but still errors. btw, I enabled ranger plugin in hdfs.
Created 06-16-2016 10:04 AM
So was that working before enabling the ranger hdfs plugin?
Created 06-16-2016 10:34 AM
not try that. I enabled ranger firstly. then try install hue. I thought it doesn't matter.
Created 06-16-2016 10:41 AM
It should not be, if confs are ok i believe restarting services might help in this case. As per http://docs.hortonworks.com/HDPDocuments/HDP2/HDP-2.3.0/bk_hadoop-ha/content/ha-nn-deploy-hue.html
Created 06-16-2016 11:11 AM
It's worked now. turnout I forgot to restart hdfs .