Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 08-08-2017 11:26 AM
I have a Kerberos enabled cluster with HDFS service installed on host1.
when i try to perform some operations on HDFS server, its failing with below error.
17/08/08 11:19:34 WARN ipc.Client: Exception encountered while connecting to the server : javax.security.sasl.SaslException: GSS initiate failed [Caused by GSSException: No valid credentials provided (Mechanism level: Failed to find any Kerberos tgt)] report: Failed on local exception: java.io.IOException: javax.security.sasl.SaslException: GSS initiate failed [Caused by GSSException: No valid credentials provided (Mechanism level: Failed to find any Kerberos tgt)]; Host Details : local host is: "host1.example.com/172.26.110.122"; destination host is: "host1.example.com":8020;
I tried to execute klist
it shoes some certificates but seems expired.
Please help me on this error.
Created 08-08-2017 11:44 AM
Please do a kinit with the hDFS keytab and see if it works:
Get Principal Name
# klist -kte /etc/security/keytabs/hdfs.headless.keytab Keytab name: FILE:/etc/security/keytabs/hdfs.headless.keytab KVNO Timestamp Principal ---- ------------------- ------------------------------------------------------ 9 06/15/2017 10:01:12 [email protected] (des-cbc-md5) 9 06/15/2017 10:01:12 [email protected] (des3-cbc-sha1) 9 06/15/2017 10:01:12 [email protected] (arcfour-hmac) 9 06/15/2017 10:01:12 [email protected] (aes256-cts-hmac-sha1-96) 9 06/15/2017 10:01:12 [email protected] (aes128-cts-hmac-sha1-96)
.
- Do a kinit
# kinit -kt /etc/security/keytabs/hdfs.headless.keytab [email protected]
.
Check the ticket.
# klist Ticket cache: FILE:/tmp/krb5cc_0 Default principal: [email protected] Valid starting Expires Service principal 08/08/2017 11:43:48 08/09/2017 11:43:48 krbtgt/[email protected]
Then try again.
.
Created 08-08-2017 11:44 AM
Please do a kinit with the hDFS keytab and see if it works:
Get Principal Name
# klist -kte /etc/security/keytabs/hdfs.headless.keytab Keytab name: FILE:/etc/security/keytabs/hdfs.headless.keytab KVNO Timestamp Principal ---- ------------------- ------------------------------------------------------ 9 06/15/2017 10:01:12 [email protected] (des-cbc-md5) 9 06/15/2017 10:01:12 [email protected] (des3-cbc-sha1) 9 06/15/2017 10:01:12 [email protected] (arcfour-hmac) 9 06/15/2017 10:01:12 [email protected] (aes256-cts-hmac-sha1-96) 9 06/15/2017 10:01:12 [email protected] (aes128-cts-hmac-sha1-96)
.
- Do a kinit
# kinit -kt /etc/security/keytabs/hdfs.headless.keytab [email protected]
.
Check the ticket.
# klist Ticket cache: FILE:/tmp/krb5cc_0 Default principal: [email protected] Valid starting Expires Service principal 08/08/2017 11:43:48 08/09/2017 11:43:48 krbtgt/[email protected]
Then try again.
.