Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 01-29-2016 04:08 AM
When i login to the ui, metrics summary for hbase is not shown. for the rest like hdfs/storm the metrics show up.
collector and ambari server are on the same host.
The exception i get in server log is:
--------------------------------
DEBUG [qtp-ambari-client-26 - /api/v1/clusters/cluster_name/services/HBASE/components/HBASE_REGIONSERVER?_=1454039202858] MetricsRequestHelper:116 - Error getting timeline metrics : Read timed out
java.net.SocketTimeoutException: Read timed out
at java.net.SocketInputStream.socketRead0(Native Method)
--------------------------------
any help would be appreciated.
Created 01-29-2016 05:45 AM
Also check for firewall/iptables issues.
Created 01-29-2016 04:12 AM
Created 01-29-2016 06:17 AM
hi Neeraj,
The Hbase ms and rs are up. i am able to see the summary. but not the graphs.
I seemed to have worked around the problem by deleting a widget. (read latency widget) and everything appeared.
even though 1 latency widget is not there.
i added a graph via ambari-grafana for read latency and the metric is now available there
Created 01-29-2016 05:45 AM
Also check for firewall/iptables issues.
Created 01-30-2016 12:33 AM
Hi rahul.
The collector and server are on the same host and so is ambari grafana
As I mentioned, removal of a widget made everything else appear. I have added a graph in grafana for the metric widget I removed
Created 01-30-2016 12:10 PM
Firewall can affect monitors sending data to collector so please make sure all servers are allowed
Created 01-30-2016 01:00 PM
@vishnu rao That sounds like a good work around. I am focusing on this message "java.net.SocketTimeoutException: Read timed out"
Red time out can occur when there is network latency. Nice explanation
For example: Let's say everything is working fine and load in the node is very high , connection is trying to read the data for metric and it cant because there is no more room to do the processing.
Created 01-31-2016 01:56 AM
aye. agree. seems to be a load issue, but its kinda strange. will debug more.
Created 01-31-2016 02:53 AM
@vishnu rao Ok. Keep us posted. If it's load issue or network overloaded then I guess we do have a root cause.
Created 01-31-2016 02:11 AM
follow the links in this page for tuning, known issues and troubleshooting Link