Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created on 08-08-2017 03:44 AM - edited 08-08-2017 03:46 AM
hi,
I am working with python and cm_api. I got the following response when I execute my script. I copied and paste the code from the cloudera blog
This is the code:
hdfs_service_config = {
'dfs_replication': 2,
}
nn_config = {
'dfs_name_dir_list': '/dfs/nn',
'dfs_namenode_handler_count': 30,
}
snn_config = {
'fs_checkpoint_dir_list': '/dfs/snn',
}
dn_config = {
'dfs_data_dir_list': '/dfs/dn1,/dfs/dn2,/dfs/dn3',
'dfs_datanode_failed_volumes_tolerated': 1,
}
hdfs.update_config(
svc_config=hdfs_service_config,
NAMENODE=nn_config,
SECONDARYNAMENODE=snn_config,
DATANODE=dn_config)cm-api (14.0.0)
Any ideas?
Created 08-09-2017 12:05 AM
Created 08-09-2017 12:05 AM
Created 08-09-2017 05:43 AM
Thank you for sharing your solution. I do need to clarify about the code from the blog. Which article was it from? Also, are you saying there was an error with the code or that you were having difficulty changing it to match your conditions?
Created 08-10-2017 12:01 AM
Hello,
Is this article: http://blog.cloudera.com/blog/2012/09/automating-your-cluster-with-cloudera-manager-api/
In the step3 ("configuring HDFS") I just get errors and errors.
My conditions matched ok with this new configuration.
Any question let me know