Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created on 05-16-2016 03:43 PM - edited 08-18-2019 06:00 AM
Hi,
It's a multi-node cluster and while starting zookeeper in ambari UI on a server (server1), it's getting failed with below error. Zookeeper server is running on remaing servers.
Can any one please help me to resolve this issue?
Created 05-16-2016 06:54 PM
Wow ... that's a problem with the RPMs I think. Here's how to fix it:
rm -r /usr/hdp/current/zookeeper-server ln -s /usr/hdp/2.2.9.0-3393/zookeeper /usr/hdp/current/zookeeper-server
Created 05-16-2016 04:03 PM
This is saying that you're missing either a ZK file or ZK symlink. Can you post the output of
ls -l /usr/hdp/current | grep zookeeper ls -l /usr/hdp/current/zookeeper-server/bin
Created 05-16-2016 04:10 PM
[root@server1 Desktop]# ls -l /usr/hdp/current/ | grep zookeeper lrwxrwxrwx 1 root root 31 May 12 23:15 zookeeper-client -> /usr/hdp/2.2.9.0-3393/zookeeper drwxr-xr-x 3 root root 4096 May 12 23:30 zookeeper-server [root@server1 Desktop]# ls -l /usr/hdp/current/zookeeper-server/bin ls: cannot access /usr/hdp/current/zookeeper-server/bin: No such file or directory [root@server1 Desktop]#
Created 05-16-2016 06:54 PM
Wow ... that's a problem with the RPMs I think. Here's how to fix it:
rm -r /usr/hdp/current/zookeeper-server ln -s /usr/hdp/2.2.9.0-3393/zookeeper /usr/hdp/current/zookeeper-server
Created 05-16-2016 07:02 PM
Thanks a lot!!
It worked!
Created 09-12-2016 05:43 AM
Thanks Jonathan, i have been battling with this for a week, this tip helped, i had symlink errors with accumulo-client installation of HDP 2.4