Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 11-21-2016 08:56 AM
After I sucessfully runned "
INSERT OVERWRITE TABLE tokenized_access_logs SELECT * FROM intermediate_access_logs;
" in Hive,
I tried to run
invalidate metadata;
in impala, it shows error timed out (code THRIFTSOCKET):None
I can see those two external tables have been successfully created on Hive.I could also see those two tables on impala but when I clicked it it shows "error load columns"
Any ideas??
Thank you
Created 11-21-2016 11:34 PM
Check the all the impala and hive demon status using the below command , if anyone one of them is not runing up please start and fire the invalidate metadata for refersh.
sudo service impala-state-store status note - if not started please replace status with start.
sudo service impala-catalog status
sudo service hive-metastore status
sudo service impala-server status
Created 11-21-2016 11:45 AM
Hi,
Thrift protocol is used for communication inside impala, as well as from impala (and catalog daemon) to hive metastore. If you see socket timeouts withing this context, most probably one service is not in good health, you should check whether the impala service instances are up-and-running: hive metastore, impala daemon, catalog daemon and impala statestore.
Regards
Miklos Szurap
Customer Operations Engineer
Created 11-21-2016 11:34 PM
Check the all the impala and hive demon status using the below command , if anyone one of them is not runing up please start and fire the invalidate metadata for refersh.
sudo service impala-state-store status note - if not started please replace status with start.
sudo service impala-catalog status
sudo service hive-metastore status
sudo service impala-server status