Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created on 01-02-2015 02:50 PM - edited 09-16-2022 02:17 AM
read about apache phoenix on
http://blog.cloudera.com/blog/2013/03/phoenix-in-15-minutes-or-less/
and
I followed the instructions on
http://phoenix.apache.org/download.html#Installation
Since I am on CDH5 I downloaded Phoenix 4.2.2 - HBase 0.98.1+
I untared the packaged and copied the phoenix-4.2.2-server.jar to lib/hbase/lib to every region server and restarted the cluster
but when I invoke phoenix via sqlline (they now include the package) bin/sqlline.py localhost
Setting property: [isolation, TRANSACTION_READ_COMMITTED]
issuing: !connect jdbc:phoenix:zookeeper.local none none org.apache.phoenix.jdbc.PhoenixDriver
Connecting to jdbc:phoenix:localhost
java.lang.UnsupportedClassVersionError: org/apache/phoenix/jdbc/PhoenixDriver : Unsupported major.minor version 51.0
at java.lang.ClassLoader.defineClass1(Native Method)
at java.lang.ClassLoader.defineClassCond(ClassLoader.java:631)
at java.lang.ClassLoader.defineClass(ClassLoader.java:615)
at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:141)
at java.net.URLClassLoader.defineClass(URLClassLoader.java:283)
at java.net.URLClassLoader.access$000(URLClassLoader.java:58)
at java.net.URLClassLoader$1.run(URLClassLoader.java:197)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)
at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
at java.lang.Class.forName0(Native Method)
at java.lang.Class.forName(Class.java:169)
at sqlline.SqlLine$DatabaseConnection.connect(SqlLine.java:4608)
at sqlline.SqlLine$DatabaseConnection.getConnection(SqlLine.java:4701)
at sqlline.SqlLine$Commands.connect(SqlLine.java:3942)
at sqlline.SqlLine$Commands.connect(SqlLine.java:3851)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:597)
at sqlline.SqlLine$ReflectiveCommandHandler.execute(SqlLine.java:2810)
at sqlline.SqlLine.dispatch(SqlLine.java:817)
at sqlline.SqlLine.initArgs(SqlLine.java:633)
at sqlline.SqlLine.begin(SqlLine.java:680)
at sqlline.SqlLine.mainWithInputRedirection(SqlLine.java:441)
at sqlline.SqlLine.main(SqlLine.java:424)
Anybody try to install phoenix on CDH - Can you share instructions
Created 01-02-2015 05:26 PM
Created 01-02-2015 05:26 PM
Created 01-05-2015 12:52 PM
Upgraded my cluster to use java 7 and it works fine now
Created 03-02-2015 01:39 PM
Hi Scratch28,
Where you able to connect to phoenix from your local machine? I have the Phonenix 4.2 on CDH 5.3.1 same as yourself but I'm having a problem described here. I've read here that there is an issue on AWS where internal and external IPs were get confused and zookeeper can't connect to HBase properly?
Thanks
J
Created 01-06-2016 07:27 PM
are you problem slove?
I have the same proble. useing CDH5.47 and install phoenix version is ( phoenix-4.5.2-HBase-1.0-bin).
my java jdk version is 1.7.0_79, .use [root@node2 bin]# ./sqlline.py node2:2181
but, it worng append:
issuing: !connect jdbc:phoenix:node2:2181 none none org.apache.phoenix.jdbc.PhoenixDriver
Connecting to jdbc:phoenix:node2:2181
16/01/07 10:46:17 WARN util.NativeCodeLoader: Unable to load native-hadoop library for your platform... using builtin-java classes where applicable
Error: ERROR 1102 (XCL02): Cannot get all table regions (state=XCL02,code=1102)
java.sql.SQLException: ERROR 1102 (XCL02): Cannot get all table regions
what can I do!
Any idea.
Created on 02-25-2016 12:31 AM - edited 02-25-2016 12:32 AM
Hi all I have question:
can I install phoenix on cdh5.5.x without parcels, I never used the parcels before, I installed cdh cluster using apt package manager on ubuntu servers