Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 04-07-2016 08:29 PM
Deploying a single node cluster. For AMBARI_METRICS service, the hdfs.rootdir had a default value of "file:///local/var/lib/ambari-metrics-collector/hbase". This gave an error while configuring the services and suggested the name should be changed. I tried hdfs://hostname:8020/apps/ams/metrics. It gives the following warning:
In embedded mode hbase.rootdir cannot point to schemaless values or HDFS, Example - file:// for localFS Ambari Metrics service uses HBase as default storage backend. Set the rootdir for HBase to either local filesystem path if using Ambari Metrics in embedded mode or to a HDFS dir, example: hdfs://namenode.example.org:8020/amshbase.
Should I be giving the local folder for HDFS? And how can I find what folder this is?
Created 04-07-2016 08:36 PM
What version of Ambari is this?
I assume the value of your config item in ams-site : "timeline.metrics.service.operation.mode" is embedded.
Please verify the config ams-hbase-site : hbase.cluster.distributed = false.
If both of these configs are as stated above, and you still get an error for hbase.rootdir = file:///local/var/lib/ambari-metrics-collector/hbase, please omit the warning and go ahead the deploy the services.
Also, please share the screenshot for the warning you see so that we can create a bug to track it.
In general, AMS operates in 2 modes.
embedded : Single AMS HBase daemon writing to local disk.
distributed : Separate AMS HBase master and RS daemons by default writing to HDFS.
Created 04-07-2016 08:36 PM
What version of Ambari is this?
I assume the value of your config item in ams-site : "timeline.metrics.service.operation.mode" is embedded.
Please verify the config ams-hbase-site : hbase.cluster.distributed = false.
If both of these configs are as stated above, and you still get an error for hbase.rootdir = file:///local/var/lib/ambari-metrics-collector/hbase, please omit the warning and go ahead the deploy the services.
Also, please share the screenshot for the warning you see so that we can create a bug to track it.
In general, AMS operates in 2 modes.
embedded : Single AMS HBase daemon writing to local disk.
distributed : Separate AMS HBase master and RS daemons by default writing to HDFS.
Created on 04-07-2016 08:59 PM - edited 08-18-2019 04:54 AM
This is Ambari 2.2.1.1
I dont see "timeline.metrics.service.operation.mode" under ams-site but it is under General. The value is embedded.
hbase.cluster.distributed = false.
Here is the warning message that I got.
Created 04-08-2016 04:17 AM
As long as you have a folder called /local in the node where you are installing file:///local/var/lib/ambari-metrics-collector/hbase is a good value for hbase.rootdir.
You can ignore the error and proceed.
But please note that AMS might be writing loads of data - so it's always better to keep it away from datanode locations.
Created 04-20-2016 09:15 PM
If there is a local Datanode consider switching to AMS distributed mode, which means AMS will write to HDFS.
https://cwiki.apache.org/confluence/display/AMBARI/AMS+-+distributed+mode
Note: In distributed mode, HBase master needs much less memory vs RS, example say you have a 50 node cluster consider these memory settings:
ams-env :: collector_heapsize = 2048
ams-hbase-env :: hbase_master_heapsize = 512
ams-hbase-env :: hbase_master_xmn = 102
ams-hbase-env :: hbase_regionserver_heapsize = 4096
ams-hbase-env :: regionserver_xmn_size = 512
Created 04-22-2016 04:23 PM
Also, for reference, you can checkout this section of the docs related to Tuning Ambari Metrics (with some guidelines) and how to setup Distributed mode.