Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created on 12-12-2018 03:55 AM - edited 09-16-2022 06:59 AM
Hello,
I installed apache kafka and sentry on CDH (5.13), but the problem is that I am not able to create roles using the command kafka-sentry. (I executed the command with a superuser account)
I found this error on my log file:
ERROR transport.TSaslTransport: SASL negotiation failure
javax.security.sasl.SaslException: GSS initiate failed [Caused by GSSException: No valid credentials provided (Mechanism level: Failed to find any Kerberos tgt)]
Any help please ?
Created 12-13-2018 04:46 AM
Thank you.
I switched kafka user and executed the privileges commands of (kafka-sentry) and the error disappears
Created 12-12-2018 04:25 AM
Created 12-13-2018 04:46 AM
Thank you.
I switched kafka user and executed the privileges commands of (kafka-sentry) and the error disappears
Created 12-13-2018 05:36 AM
Congratulations on solving the issue. Can you please mark the appropriate reply as the solution to your issue. This way it can assist others facing a similar situation.