Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 03-10-2017 06:19 PM
Team
Iam trying to setup and kerbores for my Ambari and HDP. getting bellow error while start the kerb service. p;lease help.
krb.conf::::::::::::::::::::;
more /etc/krb5.conf [libdefaults] default_realm = ******.COM [realms] ******.COM = { kdc = kerberos.******.com admin_server = kerberos.******.com master_kdc = kerberos.******.com default_domain = ******.com database_module = ldap.******.com } [domain_realm] .******.com = ******.COM ******.com = ******.COM [dbmodules] ldap.******.com = { db_library = kldap ldap_kerberos_container_dn = cn=krbcontainer,dc=******,dc=com ldap_kdc_dn = uid=admin,ou=People,dc=******,dc=com ldap_kadmind_dn = uid=admin,ou=People,dc=******,dc=com ldap_service_password_file = /etc/krb5.secrets ldap_servers = ldap://127.0.0.1 ldap_conns_per_server = 5
more /etc/krb5kdc/kadm5.acl
*/admin@D*****.COM *
Created 11-15-2023 09:55 AM
Hola a todos,
Actualice los paquetes de krb5-* a su ultima versión y se solucionó el problema.
saludos.
Created 03-10-2017 06:29 PM
where is the error? I don't see any error. Just the details of your config.
Created 03-11-2017 08:30 AM
when i do a service start
service krb5kdc start
Starting Kerberos 5 KDC: krb5kdc: cannot initialize realm ****.COM - see log file for details [FAILED]
In log file
krb5kdc: No such file or directory - while initializing database for realm ****.com
When i start kadmin:::::
service kadmin start Starting Kerberos 5 Admin Server: kadmind: Unable to load requested database module 'kldap': plugin symbol 'kdb_function_table' not found while initializing, aborting
Created 03-11-2017 06:20 PM
What is your OS?
Seems like you haven't created database for you realm.
If you have Debian/Ubuntu try
krb5_newrealm
command, else try
kdb5_util create -s -r YOUR_REALM
Created 03-13-2017 09:59 PM
@suresh krish
Follow the steps mentioned here.
Please refer to this article
http://docs.hortonworks.com/HDPDocuments/HDP2/HDP-2.5.3/bk_security/content/_kerberos_overview.html
Created 11-15-2023 08:31 AM
Hola a todos,
Alguien sabe como se arregla este problema, creo que es algo similar:
2023-11-15T15:51:02Z DEBUG Process finished, return code=1
2023-11-15T15:51:02Z DEBUG stdout=Loading random data
Initializing database '/var/kerberos/krb5kdc/principal' for realm 'IPAMASTER.WORK.COM',
master key name 'K/[email protected]'
You will be prompted for the database Master Password.
It is important that you NOT FORGET this password.
Enter KDC database master key:
Re-enter KDC database master key to verify:
2023-11-15T15:51:02Z DEBUG stderr=kdb5_util: Unable to load requested database module 'ipadb.so': plugin symbol 'kdb_function_table' not found while creating database '/var/kerberos/krb5kdc/principal'
2023-11-15T15:51:02Z DEBUG kdb5_util failed with CalledProcessError(Command ['kdb5_util', 'create', '-s', '-r', 'IPAMASTER.WORK.COM', '-x', 'ipa-setup-override-restrictions'] returned non-zero exit status 1: "kdb5_util: Unable to load requested database module 'ipadb.so': plugin symbol 'kdb_function_table' not found while creating database '/var/kerberos/krb5kdc/principal'\n")
2023-11-15T15:51:02Z DEBUG Traceback (most recent call last):
File "/usr/lib/python3.6/site-packages/ipaserver/install/krbinstance.py", line 358, in __init_ipa_kdb
ipautil.run(args, nolog=(self.master_password,), stdin=''.join(dialogue))
File "/usr/lib/python3.6/site-packages/ipapython/ipautil.py", line 600, in run
p.returncode, arg_string, output_log, error_log
ipapython.ipautil.CalledProcessError: CalledProcessError(Command ['kdb5_util', 'create', '-s', '-r', 'IPAMASTER.WORK.COM', '-x', 'ipa-setup-override-restrictions'] returned non-zero exit status 1: "kdb5_util: Unable to load requested database module 'ipadb.so': plugin symbol 'kdb_function_table' not found while creating database '/var/kerberos/krb5kdc/principal'\n")
During handling of the above exception, another exception occurred:
Traceback (most recent call last):
File "/usr/lib/python3.6/site-packages/ipaserver/install/service.py", line 635, in start_creation
run_step(full_msg, method)
File "/usr/lib/python3.6/site-packages/ipaserver/install/service.py", line 621, in run_step
method()
File "/usr/lib/python3.6/site-packages/ipaserver/install/krbinstance.py", line 361, in __init_ipa_kdb
raise RuntimeError("Failed to initialize kerberos container")
RuntimeError: Failed to initialize kerberos container
2023-11-15T15:51:02Z DEBUG [error] RuntimeError: Failed to initialize kerberos container
2023-11-15T15:51:02Z DEBUG File "/usr/lib/python3.6/site-packages/ipapython/admintool.py", line 180, in execute
return_value = self.run()
File "/usr/lib/python3.6/site-packages/ipapython/install/cli.py", line 344, in run
return cfgr.run()
File "/usr/lib/python3.6/site-packages/ipapython/install/core.py", line 360, in run
return self.execute()
File "/usr/lib/python3.6/site-packages/ipapython/install/core.py", line 386, in execute
for rval in self._executor():
File "/usr/lib/python3.6/site-packages/ipapython/install/core.py", line 431, in __runner
exc_handler(exc_info)
File "/usr/lib/python3.6/site-packages/ipapython/install/core.py", line 460, in _handle_execute_exception
self._handle_exception(exc_info)
File "/usr/lib/python3.6/site-packages/ipapython/install/core.py", line 450, in _handle_exception
six.reraise(*exc_info)
File "/usr/lib/python3.6/site-packages/six.py", line 693, in reraise
raise value
File "/usr/lib/python3.6/site-packages/ipapython/install/core.py", line 421, in __runner
step()
File "/usr/lib/python3.6/site-packages/ipapython/install/core.py", line 418, in <lambda>
step = lambda: next(self.__gen)
File "/usr/lib/python3.6/site-packages/ipapython/install/util.py", line 81, in run_generator_with_yield_from
six.reraise(*exc_info)
File "/usr/lib/python3.6/site-packages/six.py", line 693, in reraise
raise value
File "/usr/lib/python3.6/site-packages/ipapython/install/util.py", line 59, in run_generator_with_yield_from
value = gen.send(prev_value)
File "/usr/lib/python3.6/site-packages/ipapython/install/core.py", line 655, in _configure
next(executor)
File "/usr/lib/python3.6/site-packages/ipapython/install/core.py", line 431, in __runner
exc_handler(exc_info)
File "/usr/lib/python3.6/site-packages/ipapython/install/core.py", line 460, in _handle_execute_exception
self._handle_exception(exc_info)
File "/usr/lib/python3.6/site-packages/ipapython/install/core.py", line 518, in _handle_exception
self.__parent._handle_exception(exc_info)
File "/usr/lib/python3.6/site-packages/ipapython/install/core.py", line 450, in _handle_exception
six.reraise(*exc_info)
File "/usr/lib/python3.6/site-packages/six.py", line 693, in reraise
raise value
File "/usr/lib/python3.6/site-packages/ipapython/install/core.py", line 515, in _handle_exception
super(ComponentBase, self)._handle_exception(exc_info)
File "/usr/lib/python3.6/site-packages/ipapython/install/core.py", line 450, in _handle_exception
six.reraise(*exc_info)
File "/usr/lib/python3.6/site-packages/six.py", line 693, in reraise
raise value
File "/usr/lib/python3.6/site-packages/ipapython/install/core.py", line 421, in __runner
step()
File "/usr/lib/python3.6/site-packages/ipapython/install/core.py", line 418, in <lambda>
step = lambda: next(self.__gen)
File "/usr/lib/python3.6/site-packages/ipapython/install/util.py", line 81, in run_generator_with_yield_from
six.reraise(*exc_info)
File "/usr/lib/python3.6/site-packages/six.py", line 693, in reraise
raise value
File "/usr/lib/python3.6/site-packages/ipapython/install/util.py", line 59, in run_generator_with_yield_from
value = gen.send(prev_value)
File "/usr/lib/python3.6/site-packages/ipapython/install/common.py", line 65, in _install
for unused in self._installer(self.parent):
File "/usr/lib/python3.6/site-packages/ipaserver/install/server/__init__.py", line 566, in main
master_install(self)
File "/usr/lib/python3.6/site-packages/ipaserver/install/server/install.py", line 278, in decorated
func(installer)
File "/usr/lib/python3.6/site-packages/ipaserver/install/server/install.py", line 890, in install
subject_base=options.subject_base)
File "/usr/lib/python3.6/site-packages/ipaserver/install/krbinstance.py", line 215, in create_instance
self.start_creation()
File "/usr/lib/python3.6/site-packages/ipaserver/install/service.py", line 635, in start_creation
run_step(full_msg, method)
File "/usr/lib/python3.6/site-packages/ipaserver/install/service.py", line 621, in run_step
method()
File "/usr/lib/python3.6/site-packages/ipaserver/install/krbinstance.py", line 361, in __init_ipa_kdb
raise RuntimeError("Failed to initialize kerberos container")
2023-11-15T15:51:02Z DEBUG The ipa-server-install command failed, exception: RuntimeError: Failed to initialize kerberos container
2023-11-15T15:51:02Z ERROR Failed to initialize kerberos container
2023-11-15T15:51:02Z ERROR The ipa-server-install command failed. See /var/log/ipaserver-install.log for more information
[root@rhds01 ~]#
No logro encontrar cual es el problema exáctamente 😞
Help me.
saludos.
Created 11-15-2023 08:58 AM
Hola,
Ya probé creando la BD mediante el comando kdb_util y se crea sin mayor problema.
Aquí el detalle, es que dice que no encuentra una librería ipadb.so 😞
saludos.
Created 11-15-2023 09:55 AM
Hola a todos,
Actualice los paquetes de krb5-* a su ultima versión y se solucionó el problema.
saludos.