Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 08-01-2016 02:52 PM
I have configured a DistributedMapCacheClientService and a DistributedMapCacheServer which are used by the DetectDuplicate processor. But when I try to process flowfiles using the DetectDuplicate Processor I receive an error: "Detect Duplicate failed to process session due to java.nio.channels.UnresolvedAdressException". So is there any additional configuration needed? Btw, I have installed Nifi additionally on my Hortonworks Sandbox, which is running locally.
Created 08-01-2016 03:10 PM
Since you are running on a standalone NiFi instance, the MapCacheServer is running locally, then you should put 'localhost' for the property 'Server Hostname' in the client service. Let me know if it helps.
Created 08-01-2016 02:55 PM
Hi @Alexander Flick,
Could you share the configuration of your controller services? Are the two controller services running?
Created on 08-01-2016 03:02 PM - edited 08-18-2019 05:00 AM
MapCacheServer:
MapCacheClientService:
Both Controller Services are enabled but how can I check that they are running?
Created 08-01-2016 03:10 PM
Since you are running on a standalone NiFi instance, the MapCacheServer is running locally, then you should put 'localhost' for the property 'Server Hostname' in the client service. Let me know if it helps.
Created 08-01-2016 03:31 PM
Yes, that helped - it works 🙂 Thank you so much!
Created 08-29-2016 03:33 PM
In the cluster mode, if we run MapCacheServer on only NCM, does that mean once NCM fails, the MapCacheServer becomes unavailable?
Is there anyway to avoid it?
Thanks.
Created 08-29-2016 03:37 PM