Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created on
01-08-2017
06:25 PM
- last edited on
04-21-2026
05:25 AM
by
GrazittiAPI
Hi, i have just installed HDF on Ubuntu 14. When attempting to add hosts it fails with the error below.I have changed permissions of the .ssh folder and the id_rsa.pub file. I am attempting to add the machine that the ambari-server is installed on as a host. Thanks
INFO:root:BootStrapping hosts ['master.hadoop.com'] using /usr/lib/python2.6/site-packages/ambari_server cluster primary OS: ubuntu14 with user 'root'with ssh Port '22' sshKey File /var/run/ambari-server/bootstrap/8/sshKey password File null using tmp dir /var/run/ambari-server/bootstrap/8 ambari: master.hadoop.com; server_port: 8080; ambari version: 2.4.2.0; user_run_as: root INFO:root:Executing parallel bootstrap ERROR:root:ERROR: Bootstrap of host master.hadoop.com fails because previous action finished with non-zero exit code (255) ERROR MESSAGE: Permission denied (publickey,password).
If i was to install the agent manually, where can i get the package?, i can only find links to install hdp agents
Created 01-08-2017 07:14 PM
Got it.
1. ssh-keygen -t rsa
Press enter for each line
2. cat ~/.ssh/id_rsa.pub >> ~/.ssh/authorized_keys
3. chmod og-wx ~/.ssh/authorized_keys
Created 01-08-2017 07:14 PM
Got it.
1. ssh-keygen -t rsa
Press enter for each line
2. cat ~/.ssh/id_rsa.pub >> ~/.ssh/authorized_keys
3. chmod og-wx ~/.ssh/authorized_keys
Created 01-31-2017 09:41 AM
your name host, whe use ambari, not is 'localhost', its 'localhost.localdomain', because use the FQDN, try it